Croisement d'information

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'007
Appréciations reçues : 334
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 18 mai 2019, 16:13

Content d'avoir pu te dépanner ... :wink:

Merci ... pour tes remerciements ...

Bonne Continuation
1 membre du forum aime ce message.
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 18 mai 2019, 18:15

SIERREUR(INDEX(maplage;EQUIV(A25&B25;$A$2:$A$21&passagers2;0));SIERREUR(INDEX(maplage;EQUIV(A25&B25;$A$2:$A$21&passagers1;0));"Absent"))

Si en B tu ne trouves pas le premier prénom (erreur) va chercher dans la deuxième colonne des transportés c'est ça? Magnifique.


Celle ci me pose plus de problème de compréhension Dans liste, liste des conducteurs. Le but était d'aller chercher le nom des conducteurs et de lui demander à ce qu'il n'apparaisse qu'une seule fois:

SIERREUR(INDEX(maplage;EQUIV(0;NB.SI(maplage;"<"&maplage)-SOMME(NB.SI(maplage;A$1:A1));0));"")

INDEX recherche une valeur parmis la liste des conducteurs , EQUIV= trouve le N° de la ligne ( valeur recherchée 0???, NB.SI matrice des conducteurs "<" ??? et la liste des conducteurs

NB.SI(où voulez-vous rechercher ?;que voulez-vous rechercher ?)
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'007
Appréciations reçues : 334
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 18 mai 2019, 20:14

Félicitations pour ta compréhension des matricielles ... ;-b)
1 membre du forum aime ce message.
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 18 mai 2019, 22:28

lol j'ai l'impression que tu as utilisé toutes les fonctions excel existante, je suis en train de toutes les potasser!!! :lol:

Ce lien m'aide beaucoup : http://boisgontierjacques.free.fr/pages_site/sommeprod.htm
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'007
Appréciations reçues : 334
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 19 mai 2019, 10:32

Bonjour,

Si tu as vraiment envie de te plonger :playa: dans ... l'univers des Matricielles ... :8_:

dis-le moi ...je te communiquerai un ou deux sites de ' Dingos ' Complets .... :omg: :omg: :omg:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 19 mai 2019, 11:14

8[] 8[]

Oui oui oui, je veux apprendre à rédiger ces formules. Si tu as des liens je prends....

J'ai pas mal exploré hier mais suis pas au point encore.

Merci
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 24 mai 2019, 09:04

Bonjour,

J'ai un problème....

J'ai refait le tableau test avec mon tableau réel qui a des plages plus longues. J'ai bien compris la formule matricielle qui met dans l'ordre, qui enlève les vides,... J'arrive à refaire tout comme toi sauf la formule qui combine les transportés 1 et les transportés 2.

=SIERREUR(SIERREUR(INDEX($E$2:$E$4; EQUIV(LIGNES(F$2:$F2)-1; NB.SI($E$2:$E$4; "<"&$E$2:$E$4)+NB.SI($D$2:$D$6; "<"&$E$2:$E$4)+SI((NB.SI($E$2:$E$4; $E$2:$E$4)+NB.SI($D$2:$D$6; $E$2:$E$4))<=NB.SI($F$1:F1; $E$2:$E$4); 0; NB.SI($F$1:F1; $E$2:$E$4)); 0)); INDEX($D$2:$D$6; EQUIV(LIGNES(F$3:$F3)-1; NB.SI($D$2:$D$6; "<"&$D$2:$D$6)+NB.SI($E$2:$E$4; "<"&$D$2:$D$6)+SI((NB.SI($D$2:$D$6; $D$2:$D$6)+NB.SI($E$2:$E$4; $D$2:$D$6))<=NB.SI($F$1:F1; $D$2:$D$6); 0; NB.SI($F$1:F1; $D$2:$D$6)); 0)));"")

Dans mon tableau j'ai la liste des transportés 1 en E et la liste des transportés 2 en H ces colonnes s'arrêtent à la ligne 142. Biensur elles sont vide avant 142.

La je veux lui dire de prendre ma liste en E jusqu'à ce que tu arrive sur une cellule vide et ensuite reprend H jusqu'à une cellule vide et arrête toi. Met tout ça en I

je bloque
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'007
Appréciations reçues : 334
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 24 mai 2019, 10:22

Bonjour,

Pour que l'on puisse parler des mêmes choses ...

il ne faut pas hésiter à joindre ton fichier dans lequel.... ' çà coince ' :scritch:
1 membre du forum aime ce message.
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 24 mai 2019, 11:34

C'est la formule de la colonne F que je n'arrive pas à comprendre et donc à refaire sur mon tableau réel. Dans mon tableau réel j'ai la même liste de transportés 1 et 2 (trop fière j'ai compris et réécris les formules)

Dans la colonne F tu as réussi à lui dire de mettre les infos de E et D en combiné et dans l'ordre alphabetique.

Ce que j'essai de faire c'est d'étendre cette formule matricielle jusqu'à la ligne 142.
Quand j'intègre ta formule à mon tableau réel, le m'arrête en toute logique à la ligne 6

Je me suis dit, pas grave, je vais modifier la formule

SIERREUR(SIERREUR(INDEX($H$2:$H$140; EQUIV(LIGNES(I$2:$I2)-1; NB.SI($H$2:$H$140; "<"&$H$2:$H$140)+NB.SI($E$2:$E$142; "<"&$H$2:$H$140)+SI((NB.SI($H$2:$H$140; $H$2:$H$140)+NB.SI($E$2:$E$142; $H$2:$H$140))<=NB.SI($I$1:I1; $H$2:$H$140); 0; NB.SI($I$1:I1; $H$2:$H$140)); 0)); INDEX($E$2:$E$142; EQUIV(LIGNES(I$3:$I3)-1; NB.SI($E$2:$E$142; "<"&$E$2:$E$142)+NB.SI($H$2:$H$140; "<"&$E$2:$E$142)+SI((NB.SI($E$2:$E$142; $E$2:$E$142)+NB.SI($H$2:$H$140; $E$2:$E$142))<=NB.SI($I$1:I1; $E$2:$E$142); 0; NB.SI($I$1:I1; $E$2:$E$142)); 0)));"")
W
Wikimel
Membre habitué
Membre habitué
Messages : 82
Appréciation reçue : 1
Inscrit le : 2 janvier 2017
Version d'Excel : 2019

Message par Wikimel » 24 mai 2019, 11:37

j'avais pas terminé mon mail...

En fait il faut écire autant de fois qu'il y a de ligne la partie?

+NB.SI($E$2:$E$142; $H$2:$H$140))<=NB.SI($I$1:I1; $H$2:$H$140); 0; NB.SI($I$1:I1; $H$2:$H$140)); 0)); INDEX($E$2:$E$142; EQUIV(LIGNES(I$3:$I3)-1; NB.SI($E$2:$E$142; "<"&$E$2:$E$142)

Sauf que je ne sais pas à l'avance si je vais avoir 10 ou 20 transportés
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Croisement de données
    par clemscircet » 8 juillet 2015, 11:42 » dans Calc
    11 Réponses
    768 Vues
    Dernier message par clemscircet
    24 juillet 2015, 09:36
  • Croisement de 2 tableaux
    par Chtirital62 » 5 septembre 2014, 11:46 » dans Excel - VBA
    6 Réponses
    301 Vues
    Dernier message par Chtirital62
    12 septembre 2014, 13:49
  • Croisement de cellules
    par clg » 15 juin 2015, 14:41 » dans Excel - VBA
    6 Réponses
    131 Vues
    Dernier message par Banzai64
    18 juin 2015, 09:28
  • Croisement de données
    par m.agard » 23 septembre 2015, 15:22 » dans Excel - VBA
    6 Réponses
    357 Vues
    Dernier message par m.agard
    25 septembre 2015, 08:30
  • croisement donnee
    par precious » 5 décembre 2013, 15:55 » dans Excel - VBA
    2 Réponses
    281 Vues
    Dernier message par precious
    5 décembre 2013, 16:40
  • Croisement de données
    par ocidius » 3 avril 2018, 13:27 » dans Excel - VBA
    7 Réponses
    199 Vues
    Dernier message par ocidius
    12 avril 2018, 21:32