Extraire texte de chaine de caractéres

Y compris Power BI, Power Query et toute autre question en lien avec Excel
R
Remypaul
Jeune membre
Jeune membre
Messages : 26
Inscrit le : 2 août 2018
Version d'Excel : 2010

Message par Remypaul » 10 avril 2019, 18:43

Bonjour,

Je vous présente mon pb.
Dans un onglet (DATA) j'ai des cellules avec des chaines de caractères, dans un autre onglet j'ai une plage de données.
exemple:
Dans onglet DATA :
Traité par (U007001) Réalisé par (U007002)
Traité par (U007001) Réalisé par (U007002)
Traité par (U007004)
Modifié par (U007005)
Traité par (U007007) fait par (U007012)

Dans onglet plage de données :
U007001
U007003
U007004
U007005
U007006
U007008
U007009
U007010
U007011
U007012
U007014
U007015

Et je voudrais rechercher toutes les valeurs de ma plage de données dans les cellules de l'onglet DATA et affiché le résultat dans une cellule.

Je vous mets un fichier avec le résultat que je souhaite en colonne D de l'onglet DATA

Merci d'avance à tous
Classeur1.xlsm
(9.08 Kio) Téléchargé 3 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'662
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 10 avril 2019, 19:23

bonjour
un essai avec une matricielle tridactyle
remypaul.xlsm
(9.62 Kio) Téléchargé 7 fois
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 10 avril 2019, 22:35

Bonsoir le forum,

Avec une RECHERCHEV :

F3 :
=STXT(B3;CHERCHE("(";B3;1)+1;7)
G3 :
=STXT(B3;CHERCHE(")";B3;2)+2;25)
H3 :
=SIERREUR(STXT(G3;CHERCHE("(";G3;1)+1;7);"")
I3 :
=SIERREUR(RECHERCHEV(F3;'Plage de Donnée'!A:A;1;0);RECHERCHEV(H3;'Plage de Donnée'!A:A;1;0))
Recherchev.gif
Recherchev.gif (19.53 Kio) Vu 143 fois
R
Remypaul
Jeune membre
Jeune membre
Messages : 26
Inscrit le : 2 août 2018
Version d'Excel : 2010

Message par Remypaul » 11 avril 2019, 08:43

tulipe_4 a écrit :
10 avril 2019, 19:23
bonjour
un essai avec une matricielle tridactyle
remypaul.xlsm
cordialement
Bonjour,
Merci pour ton aide ça marche nickel par contre j'ai un autre soucis.
Dans une cellule (colonne D) j'ai du texte et je voudrais rechercher une valeur (colonne E) et décomposer la date qui est devant en jours (colonne F),mois (colonne G), Année (colonne H).
Sachant que le nombre de caractères varie entre la date et les valeurs de la colonne E (viennent d'une RechercheV)
Merci d'avance
Extraire date.xlsm
(13.28 Kio) Téléchargé 3 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'007
Appréciations reçues : 829
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 11 avril 2019, 09:36

Bonjour Remypail,
Bonjour Tulipe & mbbp

Dans ce cas de figure j'aime bien utiliser regexp
Remypaul.xlsm
(15.78 Kio) Téléchargé 3 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'007
Appréciations reçues : 829
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 11 avril 2019, 11:03

avec les dates (d'où l'intérêt du regexp)
après il suffit d'une formule simple pour trier ce que l'on souhaite (j'ai juste fait une MFC pour rester ici dans le pur esprit des expressions régulières)
Remypaul Uxxxxx et dates.xlsm
(16.58 Kio) Téléchargé 6 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message