Formule Somme.si.ens Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
r
relmo
Membre habitué
Membre habitué
Messages : 118
Appréciation reçue : 1
Inscrit le : 27 octobre 2015
Version d'Excel : 2007

Message par relmo » 1 avril 2019, 17:33

Bonjour à tous

Je voudrais que vous m'aidiez a mettre une formule dans la colonne E de mon tableau (Voir Pj) de façon à faire :

la somme de tous les montants perçus avant le mois en cours..

J'ai pensé à un somme.si.ens mais comment indiquer le critère 'Antérieur la date en cours" je n'y arrive pas

je joins le fichier

Merci d'avance
Exemple.xlsx
(10.56 Kio) Téléchargé 6 fois
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'503
Appréciations reçues : 123
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 1 avril 2019, 17:48

Slt relmo,

dans quelle céllule veux tu avoir la somme de tous les montants perçus avant le mois en cours?

de préference ajoute dans ton document le résultat souhaiter, ca aide beaucoup :)
Avatar du membre
oyobrans
Membre impliqué
Membre impliqué
Messages : 1'033
Appréciations reçues : 16
Inscrit le : 27 septembre 2013
Version d'Excel : 2016

Message par oyobrans » 1 avril 2019, 17:51

Bonjour,

Avec ceci ?
=SOMME.SI($B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$F$2:$F$7)
Cordialement.

Aide-toi et le ciel t'aidera.
[ GIF animé de Dave Whyte ]
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'503
Appréciations reçues : 123
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 1 avril 2019, 17:54

ou bien comme ca
=SOMME(SI($B$2:$B$7<AUJOURDHUI();$E$2:$E$12))
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'954
Appréciations reçues : 206
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 1 avril 2019, 17:57

Bonjour à tous, :pdm:

Un essai avec une colonne supplémentaire (qui peut être masquée), :lole:
Copie de Exemple.xlsx
(12.9 Kio) Téléchargé 4 fois
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
r
relmo
Membre habitué
Membre habitué
Messages : 118
Appréciation reçue : 1
Inscrit le : 27 octobre 2015
Version d'Excel : 2007

Message par relmo » 1 avril 2019, 18:03

m3ellem1 a écrit :
1 avril 2019, 17:48
Slt relmo,

dans quelle céllule veux tu avoir la somme de tous les montants perçus avant le mois en cours?

de préference ajoute dans ton document le résultat souhaiter, ca aide beaucoup :)
Bonjour,

C'est dans la colonne E que je voudrais obtenir ce résultat... C'est d'ailleurs pourquoi j'y ai inséré un commentaire et mis les résultats attendus
r
relmo
Membre habitué
Membre habitué
Messages : 118
Appréciation reçue : 1
Inscrit le : 27 octobre 2015
Version d'Excel : 2007

Message par relmo » 1 avril 2019, 18:07

oyobrans a écrit :
1 avril 2019, 17:51
Bonjour,

Avec ceci ?
=SOMME.SI($B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$F$2:$F$7)
Bonjour Oyobrans

J'ai compris le sens de la formule je vais l'adpater. sinon la somme devrait se faire pour chaque nature de bien la somme de tout ce qui a été payé précédemment.. Avec un somme.si.ens adapté a votre formule je pense que je pourrais y arriver du moins j'espère
r
relmo
Membre habitué
Membre habitué
Messages : 118
Appréciation reçue : 1
Inscrit le : 27 octobre 2015
Version d'Excel : 2007

Message par relmo » 1 avril 2019, 18:10

xorsankukai a écrit :
1 avril 2019, 17:57
Bonjour à tous, :pdm:

Un essai avec une colonne supplémentaire (qui peut être masquée), :lole:
Copie de Exemple.xlsx
Cordialement,
Bonjour Xorsankukai

Je me suis sûrement mal exprimé, c'était par exemple de faire pour tout ce qui est "Gateau"
dans la colonne C la somme de tout ce qui a été perçu avant la date qu'on insère en colonne B
Avatar du membre
oyobrans
Membre impliqué
Membre impliqué
Messages : 1'033
Appréciations reçues : 16
Inscrit le : 27 septembre 2013
Version d'Excel : 2016

Message par oyobrans » 1 avril 2019, 18:15

=SOMME.SI.ENS($F$2:$F$7;$B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$C$2:$C$7;C2)
Cordialement.

Aide-toi et le ciel t'aidera.
[ GIF animé de Dave Whyte ]
r
relmo
Membre habitué
Membre habitué
Messages : 118
Appréciation reçue : 1
Inscrit le : 27 octobre 2015
Version d'Excel : 2007

Message par relmo » 1 avril 2019, 18:17

oyobrans a écrit :
1 avril 2019, 17:51
Bonjour,

Avec ceci ?
=SOMME.SI($B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$F$2:$F$7)
La formule en m'inspirant de la votre donnera donc ceci
=SOMME.SI.ENS(F:F;C:C;C2;B:B;"<"&DATE(ANNEE(B2);MOIS(B2);JOUR(B2)))
Merci beaucoup pour le coup de pouce.. Je comprend que je n'ai pas été bien clair dans la description du post
Modifié en dernier par relmo le 1 avril 2019, 18:20, modifié 1 fois.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message