Calcul selon plusieurs conditions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
a
aordepz
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 janvier 2018
Version d'Excel : excel 2016

Message par aordepz » 31 mars 2019, 11:52

Bonjour, après beaucoup de recherches je n'arrive pas au résultat souhaité, c'est pour ça que je tourne vers vous pour trouver une solution à mon problème. Toutes les explications dans le fichier annexé. Merci beaucoup pour votre aide.
Classeur test.xlsx
(10.05 Kio) Téléchargé 7 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'397
Appréciations reçues : 241
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 31 mars 2019, 12:06

Bonjour le forum,
=A2+A5+A8
a
aordepz
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 janvier 2018
Version d'Excel : excel 2016

Message par aordepz » 31 mars 2019, 12:13

Merci, ça ne fonctionne pas, si A5 deviens positif il faut faire A2 -A5 et même chose pour A8.
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 363
Appréciations reçues : 7
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 31 mars 2019, 12:17

Hello,

En C2 :
=SI(A5<0;A2+A5;A2+A5)+SI(A8>0;A2+A8;A2+A8)-A2

R@g
a
aordepz
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 janvier 2018
Version d'Excel : excel 2016

Message par aordepz » 31 mars 2019, 12:23

Merci, ça ne fonctionne pas, si tu mets 100 en A5 le résultat devient 1200 alors que le résultat souhaité est 800.
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 363
Appréciations reçues : 7
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 31 mars 2019, 12:33

=SI(A5<0;A2-A5;A2-A5)+SI(A8>0;A2-A8;A2-A8)-A2
a
aordepz
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 janvier 2018
Version d'Excel : excel 2016

Message par aordepz » 31 mars 2019, 12:37

Super merci beaucoup ça fonctionne enfin!
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'397
Appréciations reçues : 241
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 31 mars 2019, 14:08

Re,
Rag02700 a écrit :
31 mars 2019, 12:33
=SI(A5<0;A2-A5;A2-A5)+SI(A8>0;A2-A8;A2-A8)-A2
Autrement dit :
=A2-A5-A8
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message