Besoin aide sur formules matricielles avec cellules vides

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
besoin aide
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 2 avril 2019

Message par besoin aide » 2 avril 2019, 16:04

Bonjour

Voilà, je suis complétement bloquée sur un fichier depuis 2 jours et malgré mes recherches sur internet, je désespère complètement.

J'ai construit le fichier suivant :
onglet 1 : tableau d'investissement
onglet 2 : tableau de prêt mensuel


Vous trouverez le fichier joint

Mon tableau de l'onglet 2 va jusqu'à 20 ans et se calcule automatiquement selon le nombre d'année d'emprunt bancaire.

Dans mon onglet 1, je veux reprendre les intérêts par an , donc, j'ai fait une formule matricielle avec une somme.

Pas de soucis si mon prêt est sur 20 ans. Mais si j'emprunte sur 15 ans, dans mon 2ème onglet, les lignes de 16-20 ans sont à 0 ( pas vides puisqu'il y a la formule).
De ce fait dans mon onglet 1, ma formule affiche VALEUR

Impossible de contourner le soucis, j'ai essayé sommeprod, equiv/index

Merci pour votre aide ::(
test.xlsx
(60.13 Kio) Téléchargé 8 fois
Avatar du membre
Ausecour
Passionné d'Excel
Passionné d'Excel
Messages : 3'112
Appréciations reçues : 336
Inscrit le : 31 mai 2018
Version d'Excel : 2010 FR, 2013 FR

Message par Ausecour » 2 avril 2019, 16:13

Bonjour et :bv3: sur le forum,

J'aimerais bien t'aider, mais je n'aime pas du tout les fichiers type finance, emprunts, etc... Ou plutôt, ils ne m'aiment pas, je ne les comprends jamais, et du coup... comme je ne comprends pas les formule, le fonctionnement, je ne sais pas comment corriger ton problème, je vois bien que ça renvoie #VALEUR! mais c'est tout ce que je vois pour le moment... Pourrais-tu présenter un peu ton fichier aux novices comme moi qui ne sont pas du tout du milieu? :)
Plus un sujet a un titre précis, des explications claires, et un fichier Excel bien préparé, plus il a de chances d'avoir une réponse qui répond au besoin, mettez toutes les chances de votre côté :bien:
"100% des gagnants auront tenté leur chance" :trfl:
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'014
Appréciations reçues : 258
Inscrit le : 16 mars 2017
Version d'Excel : 2010 sur PC

Message par i20100 » 2 avril 2019, 16:15

Bonjour,

à tester,
=SOMMEPROD(('Calculateur de prêt'!$A$15:$A$65000=A19)*('Calculateur de prêt'!$G$15:$G$65000))
Merci! de faire un clic sur le bouton résolu pour nous aider à t'aider.
Si vous avez un doute :
annonces/explications-et-regles-a-respecter-t13.html

isabelle
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 3 avril 2019, 09:28

Bonjour le forum,
=SOMME.SI('Calculateur de prêt'!A:A;A19;'Calculateur de prêt'!G:G)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message