Calendrier perpétuel Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 14:31

Selon une cellule ou une plage donnée (à moins qu'il est un autre endroit que j'ignore pour voir les MFC).

Menu>Format>Mise en forme conditionnelle!
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'003
Appréciations reçues : 256
Inscrit le : 16 mars 2017
Version d'Excel : 2010 sur PC

Message par i20100 » 28 mars 2019, 14:40

est ce que tu vois la couleur jaune à partir de la cellule B178 ?

mfc --> =B178=DATE(An_ref;1;(A178*7)-JOURSEM(DATE(An_ref;1;1))-2)
Merci! de faire un clic sur le bouton résolu pour nous aider à t'aider.
Si vous avez un doute :
annonces/explications-et-regles-a-respecter-t13.html

isabelle
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 14:42

Bonjour i20100

désolé pour la confusion, mais je ne vois ni la couleur jaune ni votre formule que vous venez de mettre dans le poste! :oops:
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'003
Appréciations reçues : 256
Inscrit le : 16 mars 2017
Version d'Excel : 2010 sur PC

Message par i20100 » 28 mars 2019, 14:49

re,
attention la formule est pour la cellule B178, si tu l'applique pour la plage B178:Bxxx
sinon adapte le numéro de ligne
Merci! de faire un clic sur le bouton résolu pour nous aider à t'aider.
Si vous avez un doute :
annonces/explications-et-regles-a-respecter-t13.html

isabelle
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 15:12

Bonjour i20100

D'accord, merci.

Votre proposition colore les mercredis selon la plage couverte par le MFC.

Je suis plutôt à la recherche d'une MFC qui colore toutes les dates entre les semaines 26 et 36 sauf les mercredis!

J'apprécie le temps que vous me consacrez.

A+
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 18:55

Bonjour le Forum,

ok, étant donné que ma colonne A comporte les no de semaine, je suis allé au plus simple pour le MFC :
=SOMMEPROD((A3>=26)*(A3<=36))>0
Mais cela n'exclut pas encore les mercredis de cette période (les dates étant dans la colonne B).

A+
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'003
Appréciations reçues : 256
Inscrit le : 16 mars 2017
Version d'Excel : 2010 sur PC

Message par i20100 » 28 mars 2019, 19:21

Je suis plutôt à la recherche d'une MFC qui colore toutes les dates entre les semaines 26 et 36 sauf les mercredis!
n'oublie pas la formule est pour la cellule B178, si tu l'applique pour la plage B178:Bxxx
sinon adapte le numéro de ligne
ps/ entre égal et différent, y'a pas grand chose à changer
mfc --> =B178<>DATE(An_ref;1;(A178*7)-JOURSEM(DATE(An_ref;1;1))-2)
Merci! de faire un clic sur le bouton résolu pour nous aider à t'aider.
Si vous avez un doute :
annonces/explications-et-regles-a-respecter-t13.html

isabelle
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 19:50

Merci i20100

Je teste votre proposition.

Entre temps, j'ai monté une référence pour les # de semaine comme pour pour les jours chômés (Système).

Formule MFC
=NB.SI(S_Chômées;A4)
VDMICHEL-Calendrier perpetuv2.xls
(121.5 Kio) Téléchargé 2 fois
Avatar du membre
VDMICHEL
Membre fidèle
Membre fidèle
Messages : 422
Appréciations reçues : 2
Inscrit le : 13 novembre 2013
Version d'Excel : 2010

Message par VDMICHEL » 28 mars 2019, 21:26

Bonsoir i20100,

Merci, test concluant.

Et j'ai une autre option avec
=NB.SI(S_Chômées;A4)<>NB.SI(Mercredi;B4)
.

Je ne sais si c'est optimal, mais ça fonctionne.

A+
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message