Additionner des recherchev et multiplier façon matrice

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
malicou
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 23 juillet 2018
Version d'Excel : 2010

Message par malicou » 22 mars 2019, 16:06

Bonjour à tous,

je souhaite simplifier une formule.

Voici la situation, j'ai une base de données dans un tableau 1 avec tous mes équipements et notamment, le montant de leur amortissement annuel, ...

Dans un 2nd (petit) tableau j'ai quelques équipements issus de cette base et combien de temps ils sont utilisés.

Pour ce 2nd tableau, je souhaiterai calculer le total : nombre d'heures d'utilisation * amortissement pour chacune des lignes. Je pense qu'on peut faire quelque chose comme une matrice mais il y a des recherchev dans ma formule donc je ne sais pas le faire...

Voici le type de formule à simplifier : =(RECHERCHEV(B1;Table_equipements;13;FAUX)*C1)+(RECHERCHEV(B2+1;Table_equipements;13;FAUX)*C2)+(RECHERCHEV(B3;Table_equipements;13;FAUX)*C3)+....


et le lien
https://drive.google.com/file/d/1BQm6Pj ... sp=sharing

Merci pour votre aide :)

Alice
j
jvdo
Jeune membre
Jeune membre
Messages : 43
Appréciation reçue : 1
Inscrit le : 25 juillet 2018
Version d'Excel : 2010

Message par jvdo » 22 mars 2019, 21:47

Bonsoir,

en voilà des matrices mais avec un produit "normal" :
=SOMME(--(INDEX(Table_equipements;;1)=TRANSPOSE($B$8:$B$16))*SIERREUR(--INDEX(Table_equipements;;13);0)*TRANSPOSE($C$8:$C$16))
pour C22.
A valider par CTRL+MAJ+ENTER.

Pour les autres, en C23 et C24, il suffit de changer 13 par 14 puis 15.

Cordialement
m
malicou
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 23 juillet 2018
Version d'Excel : 2010

Message par malicou » 25 mars 2019, 09:18

ça fonctionne ! Super!!!

Merci beaucoup!

Est ce que je peux encore un peu abuser et demander des explications sur la formule afin que je puisse en refaire d'autres par moi même.
Je ne trouve rien sur --INDEX et comment cela fonctionne.

Merci encore
j
jvdo
Jeune membre
Jeune membre
Messages : 43
Appréciation reçue : 1
Inscrit le : 25 juillet 2018
Version d'Excel : 2010

Message par jvdo » 25 mars 2019, 15:35

Bonjour,

1)
SpoilerAfficher
Je ne trouve rien sur --INDEX et comment cela fonctionne
.... c'est que tu ne sais pas chercher!!!
Même l'aide en ligne excel permet de comprendre le fonctionnement de base d'INDEX().
Pour plus de détails, d'astuces et d'exhaustivité, toujours se référer au site de JBoisgontier.
Là tu trouveras tout sur INDEX()

2) comprendre la formule :
Quand tu es dans cette situation, décompose la formule en chacun de ses membres sur un coin de ta feuille.
Dans =SOMME(--(INDEX(Table_equipements;;1)=TRANSPOSE($B$8:$B$16))*SIERREUR(--INDEX(Table_equipements;;13);0)*TRANSPOSE($C$8:$C$16)) tu as 3 composants :
  • --(INDEX(Table_equipements;;1)=TRANSPOSE($B$8:$B$16))
  • SIERREUR(--INDEX(Table_equipements;;13);0)
  • TRANSPOSE($C$8:$C$16))
Regarde dans ton fichier ce que cette décomposition donne.

Cordialement
xlpratique.matrices_divers.xlsx
(113.57 Kio) Téléchargé 5 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message