Aide formule Excel SVP... Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
atlonia
Membre fidèle
Membre fidèle
Messages : 427
Inscrit le : 10 mai 2017
Version d'Excel : 2007 FR

Message par atlonia » 5 mars 2019, 14:20

Bonjour à tous,

Je planche depuis quelques jours sur cette formule :
=SOMME.SI.ENS(ESPECES!G:G;ESPECES!B:B;">=01/01/2019";ESPECES!B:B;"<=31/01/2019")
qui est sensée me donner le total du mois de janvier de la feuille "ESPECES" dans la feuille "RECAPITULATIF" cellule (H2)...

Mais le résultat affiché n'est pas bon... :scritch:
En effet sdans la feuille "ESPECES", ils n'y a que deux lignes pour janvier, une entrée et une sortie du même montant...
Je devrais donc avoir "0" dans ma cellule (H2), hors ce n'est pas le cas... :??

Le problème est le même pour la cellule (G2) qui concerne la feuille "C.MUTUEL"... ::(

Quelqu'un a-t-il la solution ?... :)
S'il a l'explication qui va avec, ça serait le top... ;-b)

Merci à vous... :)

Mon fichier joint :
Classeur_Test.xlsx
(27.76 Kio) Téléchargé 2 fois
Modifié en dernier par atlonia le 5 mars 2019, 14:23, modifié 1 fois.
Avatar du membre
Pedro22
Membre impliqué
Membre impliqué
Messages : 2'542
Appréciations reçues : 255
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 5 mars 2019, 14:22

Bonjour,

Pour Excel, ça c'est du texte, pas une date :
">=01/01/2019"
Ecrit plutôt :
">="&DATEVAL("01/01/2019")
Ou :
">="&DATE(2019;1;1)
PS : une date est stockée par les tableurs sous forme de nombre (un nombre de jour depuis une date de référence). Le format "01/01/2019" n'est qu'une histoire d'affichage. Excel comprendrait aussi bien si tu écrivais :
">=43466"
1 membre du forum aime ce message.
Le problème n'est pas de ne pas savoir, le problème est de ne pas chercher...
Ton problème est résolu ? N'oublie pas de l'indiquer :
Avatar du membre
CB60
Membre impliqué
Membre impliqué
Messages : 2'399
Appréciations reçues : 17
Inscrit le : 14 mai 2007
Version d'Excel : 2003

Message par CB60 » 5 mars 2019, 14:28

bonjour
Peut être cela:
=SOMMEPROD((C.MUTUEL!G5:G8)*(C.MUTUEL!B5:B8>=1/1/2019)*(C.MUTUEL!B5:B8<=31/1/2019))
Avatar du membre
atlonia
Membre fidèle
Membre fidèle
Messages : 427
Inscrit le : 10 mai 2017
Version d'Excel : 2007 FR

Message par atlonia » 5 mars 2019, 14:38

Merci Pedro pour ta réponse rapide, :good:

Mais je n'y arrive pas, voilà ce que j'ai écrit :
=SOMME.SI.ENS(ESPECES!G:G;ESPECES!B:B;">=&DATEVAL("01/01/2019")";ESPECES!B:B;"<=&DATEVAL("31/01/2019")")
Excel me dit qu'il y a une erreur... ::(

Saurais-tu voir ou elle est ?

Merci.
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'498
Appréciations reçues : 145
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 5 mars 2019, 14:45

Bonjour tout le monde,
Excel me dit qu'il y a une erreur... ::(

Saurais-tu voir ou elle est ?
Regarde bien la formule de Pedro22, tu as oublié un " , :P
">="&DATEVAL("01/01/2019")
Cordialement,
1 membre du forum aime ce message.
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Avatar du membre
atlonia
Membre fidèle
Membre fidèle
Messages : 427
Inscrit le : 10 mai 2017
Version d'Excel : 2007 FR

Message par atlonia » 5 mars 2019, 15:46

Bonjour xorsankukai et CB60,

CB60, Merci, J'ai testé ta formule, mais ou je m'y prend mal, elle ne fonctionne pas... :scritch:

xorsankukai, Merci de m'avoir fait remarquer cette erreur, la formule fonctionne, mais il subsiste un problème :

Après plusieurs changement de dates, j'ai remarqué que le calcul ne se faisant que sur la colonne (G) "Solde" était faussé par le fait que les débits en colonne (E) n'étaient pas pris en compte...

Je crois que que j'ai mis le doigt sur le vrai problème... :??
Il faudrait donc que le calcul soit fait non pas sur le colonne (G), mais sur la colonne (F) "Crédits" moins la colonne (E) "Débits" pour que le résultat final soit juste...

Je cherche en fait à adapter la formule qui se trouve en (A27) qui fonctionne très bien et qui réactualise les dates automatiquement au fur et à mesure que les jours, les mois et les années passent.

Merci encore à tous.
Avatar du membre
atlonia
Membre fidèle
Membre fidèle
Messages : 427
Inscrit le : 10 mai 2017
Version d'Excel : 2007 FR

Message par atlonia » 5 mars 2019, 19:28

bonsoir à tous,

J'ai contourné le problème en doublant ma formule... :youhou:
=SOMME.SI.ENS(ESPECES!$F:$F;ESPECES!$B:$B;">=01/"&MOIS(1&F$2)&"/"&ANNEE(AUJOURDHUI());ESPECES!$B:$B;"<="&JOUR(DATE(ANNEE(AUJOURDHUI());MOIS(1&F$2)+1;1)-1)&"/"&MOIS(1&F$2)&"/"&ANNEE(AUJOURDHUI()))
dans deux cellules masquées, 1 pour la colonne Crédits et une pour la colonne débit.
Puis dans mon récap, je fais la soustraction des deux résultats obtenus.

Merci à vous pour votre aide... :sp:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message