Ne pas afficher une valeur

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Mike-BZH
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 12 mai 2019
Version d'Excel : 2016 Professional Plus

Message par Mike-BZH » 27 mai 2019, 06:31

Bonjour à tous ;-)

J'ai à nouveau un p'tit problème :mrgreen:

J'aimerai que si la somme est inférieur à 0 que rien ne s'affiche dans la cellule Sup:
Valeur.jpg
Valeur.jpg (50.49 Kio) Vu 102 fois
J'ai fouillé un peu sur internet, trouvé quelques astuces mais rien n'a fonctionné?

Le fichier Excel:
Total présence 2019 aide forum.xlsx
(33.15 Kio) Téléchargé 12 fois
Merci d'avance pour votre aide :wink:
Avatar du membre
jarodness21
Membre habitué
Membre habitué
Messages : 95
Appréciations reçues : 5
Inscrit le : 8 juillet 2015
Version d'Excel : 2016 FR

Message par jarodness21 » 27 mai 2019, 06:56

bonjour

tu as essayé ceci:
=SI((C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)<0;"";SI((C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)<"705:00";(C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)-"705:00";0))

cordialement

Jarodness
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'558
Appréciations reçues : 152
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 27 mai 2019, 08:15

Bonjour Mike-BZH, jarodness (sympa l'avatar , :D ), le forum,

Un autre essai.....

En AM7 :
=SI(SOMME.SI(B6:AK6;"Sup";B7:AK7)<0;"";SI(SOMME.SI(B6:AK6;"Sup";B7:AK7)<"705:00";SOMME.SI(B6:AK6;"Sup";B7:AK7)-"705:00";0))
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
M
Mike-BZH
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 12 mai 2019
Version d'Excel : 2016 Professional Plus

Message par Mike-BZH » 27 mai 2019, 10:00

Merci à tous les deux mais quand je mets vos formules ça ne foncionnent pas?

Ce que j'avais vu sur internet c'était pas rapport ça:

SIERREUR

ESTERREUR

Mais je n'ai pas réussit non plus avec ça...
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'105
Appréciations reçues : 165
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 27 mai 2019, 11:07

bonjour
a tester
=MAX(SOMMEPROD((B7:AM7)*($B$6:$AM$6="sup"));0)
cordialement
c'est en cherchant qu'on trouve
M
Mike-BZH
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 12 mai 2019
Version d'Excel : 2016 Professional Plus

Message par Mike-BZH » 27 mai 2019, 14:04

Ca ne fonctionne pas non plus.
Avatar du membre
teten1
Membre fidèle
Membre fidèle
Messages : 324
Appréciations reçues : 17
Inscrit le : 13 avril 2016
Version d'Excel : 2010

Message par teten1 » 27 mai 2019, 14:43

Bonjour,
Un essai
Christelle
Copie de Total présence 2019 aide forum.xlsx
(33.21 Kio) Téléchargé 4 fois
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'558
Appréciations reçues : 152
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 27 mai 2019, 15:00

Re,

il y a un truc qui me chiffonne.....
=SI((C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)<"705:00";(C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)-"705:00";0)
Dans ta formule de base tu dis : si somme...<705 alors somme....-705 sinon 0. ( le résultat sera donc toujours négatif ?).
Ensuite, tu voudrais si somme<0, (donc négatif) alors rien..... :??

Je loupe quelque chose ?
Que veux-tu afficher exactement ?

Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
M
Mike-BZH
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 12 mai 2019
Version d'Excel : 2016 Professional Plus

Message par Mike-BZH » 27 mai 2019, 20:17

teten1 a écrit :
27 mai 2019, 14:43
Bonjour,
Un essai
Christelle
Merci Christelle mais du coup la il ne m'affiche plus les heures Sup??
xorsankukai a écrit :
27 mai 2019, 15:00
Re,

il y a un truc qui me chiffonne.....
=SI((C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)<"705:00";(C7+F7+I7+O7+R7+X7+AA7+AD7+AG7+AJ7)-"705:00";0)
Dans ta formule de base tu dis : si somme...<705 alors somme....-705 sinon 0. ( le résultat sera donc toujours négatif ?).
Ensuite, tu voudrais si somme<0, (donc négatif) alors rien..... :??

Je loupe quelque chose ?
Que veux-tu afficher exactement ?
En faite je souhaiterais que s'il n'y à pas de dépassement des 705 heures rien ne s'affiche dans la cellule "Sup"

si somme...<705 alors somme....-705 sinon 0, dans ce cas il ne devrait pas avoir de négatif si les heures autorisées ne sont pas dépassées?

Je me trompe peut être?
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'558
Appréciations reçues : 152
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 28 mai 2019, 08:09

Bonjour,
En faite je souhaiterais que s'il n'y à pas de dépassement des 705 heures rien ne s'affiche dans la cellule "Sup"
Donc, n'afficher que la différence de somme - 705 ?
Tant qu'on en en dessous de 705, on affiche rien, dès qu'on dépasse, on affiche la différence ?
Total présence 2019 aide forum.xlsx
(34.81 Kio) Téléchargé 2 fois
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message