Problème sur formules matricielles Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
j
jxei148
Jeune membre
Jeune membre
Messages : 22
Inscrit le : 7 février 2011
Version d'Excel : 2016 FR

Message par jxei148 » 13 février 2019, 12:31

Bonjour à tous,
Je cherche à faire des stats sur des effectifs avec 3 formules matricielles qui m'ont l'air correctes (à moi :-)) mais qui ne fonctionnent pas.
Quelqu'un peut-il me dépanner ? Fichier en PJ, formules en colonne Z.
MERCI !
stats.xlsx
(59.91 Kio) Téléchargé 5 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'151
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 13 février 2019, 12:43

bonjour,

utilise sommeprod (pas de validation matricielle)
=SOMMEPROD((H2:H310="Lille")*(U2:U310))
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 février 2019, 12:55

Bonjour le forum,
=SOMME.SI.ENS(U:U;H:H;"Lille")
j
jxei148
Jeune membre
Jeune membre
Messages : 22
Inscrit le : 7 février 2011
Version d'Excel : 2016 FR

Message par jxei148 » 13 février 2019, 12:58

Oui merci H2SO4, c'est une solution tout comme les fonctions BDSOMME ou SOMME.SI mais je souhaitais utiliser, pour l'exercice, une vraie formule matricielle :-))
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 février 2019, 13:01

Re,
=SOMME((H4:H310="Lille")*(U4:U310))
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'151
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 13 février 2019, 13:03

bonjour,

ok j'avais pas compris la demande

voici une correction (validation matricielle) les vecteurs doivent avoir le même nombre d'éléments
=SUM((H2:H310="Lille")*(U2:U310))
j
jxei148
Jeune membre
Jeune membre
Messages : 22
Inscrit le : 7 février 2011
Version d'Excel : 2016 FR

Message par jxei148 » 13 février 2019, 13:16

J'ai compris mon erreur. Les vecteurs n'étaient pas de même longueur.... MERCI à tous, tout fonctionne !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message