Conditions si multiples ? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Avatar du membre
Mishayou
Jeune membre
Jeune membre
Messages : 15
Inscrit le : 31 juillet 2018
Version d'Excel : excel 2010

Message par Mishayou » 25 janvier 2019, 14:29

Bonjour,

Je souhaite connaitre le moyen d'automatiser mon calcul (voir le fichier ci joint) :
Colonne F "résultat" > Si la valeur dans E est supérieur à 100% alors on affiche 30, si elle devient supérieur à 120 % alors on affiche 36 ect... en fonction de l'échelle que j'ai affiché de C12 à D18 (en jaune).

J'ai pensé utiliser le SI mais il ne m'affiche pas le bon résultat lorsque F dépasse la seconde condition...

En espérant être claire.

Merci par avance.
REMU RSC.xlsx
(11.98 Kio) Téléchargé 5 fois
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 25 janvier 2019, 14:45

Bonjour,

Une proposition pour la première formule :
=SI(E3>=$C$18;$D$18;SI(E3>=$C$17;$D$17;SI(E3>=$C$16;$D$16;SI(E3>=$C$15;$D$15;SI(E3>=$C$14;$D$14;SI(E3>=$C$13;$D$13;SI(E3>=$C$12;$D$12;0)))))))

La formule peut être étendue vers le bas.
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Avatar du membre
Mishayou
Jeune membre
Jeune membre
Messages : 15
Inscrit le : 31 juillet 2018
Version d'Excel : excel 2010

Message par Mishayou » 25 janvier 2019, 14:49

Génial, j'allais justement essayer la solution de mettre plusieurs SI, j'aurai surement oublier le figeage des cellules !!!

<3

Bonne journée !
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'762
Appréciations reçues : 194
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 25 janvier 2019, 14:50

Bonjour,



:P


oops doublé par Pédro … bonjour Pédro ::D
1 membre du forum aime ce message.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 26 janvier 2019, 01:25

Bonjour Mishayou, le forum,

:bv:
 
tu a écrit :Colonne F "résultat" > Si la valeur dans E est supérieure à 100% alors on affiche 30
regarde cette copie d'écran de ton fichier joint :
Screen.jpg
Screen.jpg (46.3 Kio) Vu 159 fois
dans la barre de formule, on peut lire la formule complète que tu as utilisée ; d'après les différentes conditions, ainsi que d'après ton résultat en F6 (que tu as dit être juste), tu t'es trompée dans ton énoncé ; tu aurais dû écrire :

« Si la valeur dans E est supérieure ou égale à 100% alors on affiche 30 »

d'ailleurs, j'vois que Pedro s'y est pas trompé, car il a utilisé dans sa formule des signes « >= »  et pas  « > »  :good:

je te retourne ton fichier modifié :
REMU RSC.xlsx
(10.86 Kio) Téléchargé 2 fois
tu verras cette formule en F3, qui évite de multiples SI() :

=SIERREUR(RECHERCHEV(E3;C$12:D$18;2;-1);0)

dhany
1 membre du forum aime ce message.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Conditions multiples !
    par SAER » 1 avril 2020, 21:13 » dans Excel - VBA
    7 Réponses
    88 Vues
    Dernier message par tulipe_4
    2 avril 2020, 18:41
  • Conditions multiples
    par goam » 8 août 2019, 12:21 » dans Excel - VBA
    4 Réponses
    293 Vues
    Dernier message par goam
    8 août 2019, 15:47
  • Conditions multiples
    par ACCLPC » 30 septembre 2014, 18:21 » dans Excel - VBA
    5 Réponses
    437 Vues
    Dernier message par mbbp
    30 septembre 2014, 18:51
  • Conditions Multiples
    par Laurent59 » 1 novembre 2014, 22:24 » dans Excel - VBA
    5 Réponses
    379 Vues
    Dernier message par Laurent59
    2 novembre 2014, 14:16
  • Conditions Multiples
    par Steve99 » 28 avril 2020, 22:08 » dans Excel - VBA
    4 Réponses
    29 Vues
    Dernier message par JoyeuxNoel
    28 avril 2020, 22:21
  • Conditions multiples
    par devito » 6 septembre 2019, 19:43 » dans Excel - VBA
    2 Réponses
    83 Vues
    Dernier message par devito
    6 septembre 2019, 22:12