Comptage creneau horaire d une salle Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
sat3367
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 17 mai 2018
Version d'Excel : 2010

Message par sat3367 » 17 janvier 2019, 12:40

Bonjour a tous et a toutes

voici mes donnees
o5 et N5 format texte
je dois gerer le nombre de creneau horaire d une salle
exemple
feuille Activite
cellule O5 un creneau commence a 09h30
cellule N5 se finit a 11h30

j ai donc 3 creneaux horaires
premier 09h00 10h00
2eme 10h00 11h00
3eme 11h00 12h00

j aimerais donc extraire sur une autre feuille
09h00 10h00 1
10h00 11h00 1 etc .....

la cellule O5 peut prendre les valeurs de 08h00 a 18h00 et N5 08h00 19h00

j ai essaye avec des si et des ou mais ca ne me va pas car

=SI(ET(Activité!O5>"0900";Activité!O5<="1000");1;0) ecrit 0
=SI(ET(Activité!O5>"1000";Activité!O5<="1100");1;0) ecrit 0
=SI(ET(Activité!O5>"1100";Activité!O5<="1200");1;0) ecrit 1

2 eme essai avec ou
=SI(OU(Activité!N5>"0900";Activité!O5<="1000");1;0) ecrit 1
=SI(OU(Activité!N5>"1000";Activité!O5<="1100");1;0) ecrit 0
=SI(OU(Activité!N5>"1100";Activité!O5<="1200");1;0) ecrit 1
=SI(OU(Activité!N5>"1200";Activité!O5<="1300");1;0) ecrit 1 ????

on m a conseille d utilise fonction tempsval()
mais la je ne fais que convertir l heure en format hexa
=SI(ET(Activité!O5>TEMPSVAL("09:00");Activité!O5<=TEMPSVAL("10:00"));1;0)

merci de votre aide

je viens de trouver cela sur le net je ne sais pas si cela peut marcher ( en adaptant bien sur )
Pour la plage [18:00,19:00[ :
=NB.SI(B1:B10;"<19:00")-NB.SI(B1:B10;"<18:00")
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'017
Appréciations reçues : 303
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 17 janvier 2019, 13:33

Bonjour,

Le problème vient du fait que le format horaire n'est pas un format valide au sens où Excel le comprend donc voici une solution parmi d'autres.
Tout d'abord, transformer tes heures en heures valides avec par exemple, la formule ci-dessous (remplacement du h par les deux points) :
GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2)
Ensuite, transformer cette chaîne en valeur numérique :
CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))
où 9:30 vaut 0,395833333333333 et 11:30 vaut 0,479166666666667 car il te faut savoir qu'une heure pour Excel est la 24 ème partie de l'unité qui elle représente le jour donc, 01:00 (1 heure) = 1/24 = 0,0416666666666667
Pour ensuite faire une comparaison comme montré dans tes formules il te faut faire la division de l'heure par 24 donc, pour 9 heure, c'est :
=9/24
La formule finale est :
=SI(ET(CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))>9/24;CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))<=10/24);1;0)
avec la comparaison des heures, ici pour 9 heure :
CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))>9/24
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
s
sat3367
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 17 mai 2018
Version d'Excel : 2010

Message par sat3367 » 21 janvier 2019, 13:10

hello
merci de l aide mais la ca ne marche que pour un creneau entre 09h et 10h pas pour un creneau 09h15 10h15
meme si on ecrit
celulle 1
=SI(ET(CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))>9/24;CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))<=10/24);1;0)
celulle 2
=SI(ET(CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))>10/24;CNUM(GAUCHE(Activité!O5;2)&":"&DROITE(Activité!O5;2))<=11/24);1;0)
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 21 janvier 2019, 13:45

Bonjour sat, bonjour Theze

as-tu un bout de fichier excel ?

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'017
Appréciations reçues : 303
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 21 janvier 2019, 16:21

Bonjour, Bonjkour Steelson (°v°)°,

Remplaces 9 par 9,25 (pour 9:15 heure) et 10 par 10,25 (pour 10:15 heure) et tu verras !
Voici un petit classeur avec les formules et MFC :
Modif heures avec MFC.xlsx
(12.03 Kio) Téléchargé 3 fois
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
s
sat3367
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 17 mai 2018
Version d'Excel : 2010

Message par sat3367 » 22 janvier 2019, 09:56

Bonjour theze

ceci fonctionne pas de soucis
mais en fait ce dont j ai besoin c est de compter les creneaux par heure

quelqu un utilise la salle de 09h30 (celulle A1) a 11h30 ( B1) ceci est variable

il me faudrait
09h00 10h00 1 creneau
10h00 11h00 1
11h00 12h00 1
12h00 13h00 0

utilisation de 14h15 16h15

14h00 15h00 1
15h00 16h00 1
16h00 17h00 1
test creneau.xlsx
(9.64 Kio) Téléchargé 4 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 22 janvier 2019, 11:11

Ah, enfin un fichier ...
Pourquoi ne pas utiliser les heures en format "heures" ?
=SI(ET($A6<C$5;$B6>C$4);"pris";"")
là on se simplifie quand même beaucoup les formules !
test creneau.xlsx
(9.71 Kio) Téléchargé 6 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'017
Appréciations reçues : 303
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 22 janvier 2019, 11:51

Ton classeur avec une MFC :
test creneau avec MFC.xlsx
(9.63 Kio) Téléchargé 5 fois
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
s
sat3367
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 17 mai 2018
Version d'Excel : 2010

Message par sat3367 » 25 janvier 2019, 09:00

merci beaucoup ca marche super bien
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message