Problème avec la Fonction SI et ACB risque inondation Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
E
EB08
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 31 décembre 2018
Version d'Excel : 2016 FR

Message par EB08 » 31 décembre 2018, 08:45

Bonjour à tous , étudiante en gestion des risques naturels je doit réaliser une analyse coûts/bénéfice pour cela je doit calculer les coûts de dommages sur des habitation en fonction de la hauteur d'eau et de différents facteurs tels que Maison individuel ou collectives, étages ou non, présence d'un sous sol.

Pour cela j'utilise donc un tableur excel qui recense tout mes enjeux ainsi qu'un tableau avec les coûts en fonction des hauteurs d'eau et des différentes caractéristiques. Mais je bloque sur ma formule à partir du moment ou il y'a de l'eau dans le sous sol et au RDC (et que les valeur sont différentes) pour les habitats collectifs aucun problème car la hauteur d'eau importe peu pour les sous-sols par contre pour les habitat collectifs il peut y avoir de grosse différences. Je sollicite donc votre d'aide pour m'aider a prendre en compte dans ma formule les hauteur d'eau en sous-sol si il y'a aussi de l'eau au RDC.

J’espère avoir été assez clair je met en pièce jointe un fichier excel avec les valeurs de dédommagement et quelques exemples d'enjeux.

Merci d'avance
Classeur1.xlsx
(329.03 Kio) Téléchargé 9 fois
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'028
Appréciations reçues : 292
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 31 décembre 2018, 11:10

Bonjour

Avec ce type de grille, on n'imbrique pas des SI mais on utilise RECHERCHEV avec le dernier argument à vrai

Il serait bien d'énoncer tes règles.

Je n'ai pas tout décoder mais pour l'habitat individuel, ceci semble OK
=RECHERCHEV(Q3*100;AF:AJ;2+SI(G3="Oui";1;0);1)+SI(G3="oui";RECHERCHEV(Q3*100;AF:AJ;5;1);0)+SI(ET(Q3=0;P3>0);RECHERCHEV(P3*100;AF:AJ;3;1))
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
E
EB08
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 31 décembre 2018
Version d'Excel : 2016 FR

Message par EB08 » 31 décembre 2018, 14:02

Bonjour, merci beaucoup votre réponse m'a beaucoup aidé à trouver une solution j'ai juste un dernier problème.
Au final j'obtient 2 formules une pour les habitations individuelles et une pour les habitations collectives mais je n'arrive pas à les combiner pourriez vous encore m'aider?

Voici la formule 1 pour les habitations individuelles:
=SI(P3>=1,35;"SUBMERSION";SI($B3="HabitatIndividuel";SI(G3="Oui";RECHERCHEV(P3*100;AF:AL;3;VRAI);0)+SI(F3>0;RECHERCHEV(Q3*100;AF:AL;5;VRAI);RECHERCHEV(Q3*100;AF:AL;4;VRAI))))

Et la formule 2 pour les habitations collectives:
=SI(P7>=1,35;"SUBMERSION";SI($B7="HabitatCollectif";SI(K7="Oui";RECHERCHEV(P7*100;AF:AL;6;VRAI)*J7;0)+SI(I7>0;RECHERCHEV(Q7*100;AF:AL;7;VRAI)*I7)))

Merci encore
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'028
Appréciations reçues : 292
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 31 décembre 2018, 17:42

RE

A priori
=SI(P3>=1,35;"SUBMERSION";SI($B3="Habitat Individuel";SI(G3="Oui";RECHERCHEV(P3*100;AF:AL;3;VRAI);0)+SI(F3>0;RECHERCHEV(Q3*100;AF:AL;5;VRAI);RECHERCHEV(Q3*100;AF:AL;4;VRAI));SI(K3="Oui";RECHERCHEV(P3*100;AF:AL;6;VRAI)*J3;0)+SI(I3>0;RECHERCHEV(Q3*100;AF:AL;7;VRAI)*I3;0)))
mais les résultats diffèrent de ceux d'origine...
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
E
EB08
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 31 décembre 2018
Version d'Excel : 2016 FR

Message par EB08 » 2 janvier 2019, 17:05

Merci beaucoup grâce à tes réponses j'ai réussi.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message