fonction SI / SAUF SI / DIFFÉRENT

Y compris Power BI, Power Query et toute autre question en lien avec Excel
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'171
Appréciations reçues : 377
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 décembre 2018, 17:01

bonjour,

la logique pour les formules echelle en colonne D
=SI($F$8="standard";SI(ET($F$4>C10;$F$4<=C11);$F$6;0);SI(GAUCHE(A11;TROUVE(" ";A11)-1)="D"&$F$8;$F$6;0))
si standard et si la hauteur demandée est > que la hauteur de l'échelle de la ligne précédente et <= la hauteur de l'échelle de la ligne en cours, on affiche la quantité demandée sinon 0
si non standard, on affiche la quantité demandée du modèle demandé (partie gauche du libellé en colonne A = "D" + modèle demandé)

la logique pour les formules rallonge en colonne D sauf dernière ligne
=SI($F$8<>"standard";SI(($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22>0.5;ENT(ARRONDI(0.5+($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22;1));0);0)
si non standard,
SOMMEPROD($C$11:$C21*$D$11:$D21) donne la hauteur atteinte avec les composants sélectionnés, y compris les rallonges s'il y en a
$F$4-SOMMEPROD($C$11:$C21*$D$11:$D21) donne la hauteur qui manque pour obtenir la hauteur demandée
($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22 donne le nombre de rallonges nécessaires du type envisagé, pour atteindre la hauteur demandée
SI(($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22>0.5, si le nombre de rallonge de la longueur envisagée est > .5, on calcule le nombre de rallonges, sinon 0

la logique pour les formules rallonge en colonne D pour la dernière ligne

même formule que ci-dessus, si ce n'est qu'il faut au minimum une rallonge si on n'a pas encore atteint la hauteur demandée.
=SI($F$8<>"standard";SI(($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22>0;ENT(ARRONDI(1+($F$4-SOMMEPROD($C$11:$C21*$D$11:$D21))/C22;1));0);0)
1 membre du forum aime ce message.
c
chinsko
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 3 janvier 2014
Version d'Excel : 2013 FR

Message par chinsko » 23 décembre 2018, 11:35

bonjour,

merci beaucoup pour les explications.

bonnes fêtes.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message