Mise en surbrillance cellules en comparant deux feuilles

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JYW
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 8 décembre 2018
Version d'Excel : 2016

Message par JYW » 8 décembre 2018, 12:22

Bonjour,
Tout d’abord, merci et bravo pour ce forum grâce auquel je me suis déjà dépanné quelques fois et sur lequel je pose aujourd’hui ma première question.
Je précise que j’ai un niveau Excel proche du néant et que si la réponse pouvait être compréhensible par un enfant ça m’irait bien ;;)
Voici la question :
J’ai un classeur avec deux feuilles dont chacune contient, en autres, une colonne avec des références. J’aurais besoin de mettre en surbrillance les références de la feuille 1 qui se trouvent également dans la feuille 2.
D’avance merci pour votre aide précieuse
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 8 décembre 2018, 13:23

Bonjour,
Je précise que j’ai un niveau Excel proche du néant et que si la réponse pouvait être compréhensible par un enfant ça m’irait bien ;;)
Et tu ne fournis pas de fichier modèle !? 8[]

Que vas-tu donc faire quand on te dis : MFC sur ta feuille 1 applicable à ta plage-colonne de référence, et que la formule conditionnelle est =NB.SI(PlageColonneFeuille2[enréfabsolues];CellSupérieurePlageFeuille1[enréfrelative])

Cordialement.
J
JYW
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 8 décembre 2018
Version d'Excel : 2016

Message par JYW » 8 décembre 2018, 16:24

::( je vais commencer par me demander quelle langue tu parles !
Plus sérieusement, merci bcp pour ta réponse rapide. Ça aurait probablement été mieux avec le fichier mais il s’agit d’un doc professionnel que je ne peux pas diffuser. Je vais tacher de comprendre grâce à ta réponse devant le classeur.
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 8 décembre 2018, 16:32

Pour ton information, le fichier qu'on ne peut produire n'est jamais un argument recevable, un fichier ça se fabrique !
J
JYW
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 8 décembre 2018
Version d'Excel : 2016

Message par JYW » 8 décembre 2018, 17:26

Fort juste. Je vais faire ça si j’ai un pb de compréhension ; je découvre le fonctionnement du forum
J
JYW
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 8 décembre 2018
Version d'Excel : 2016

Message par JYW » 10 décembre 2018, 09:21

Bonjour MFerrand,
Effectivement, difficile de comprendre sans un fichier modèle. Du coup, j'ai mis un tableau équivalent en PJ.
D'avance, merci pour ton aide.
MFC 2 feuilles.xlsx
(17.97 Kio) Téléchargé 2 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 10 décembre 2018, 13:59

Bonjour,

Une Mise en forme conditionnelle qui va colorer en jaune des références de Feuil1 présentes dans Feuil2 :
-On sélectionne sur Feuil1 la plage des références : A2:A293 (la MFC s'appliquera à cette plage).
-On clique sur Mise en forme conditionnelle > Nouvelle règle > Utiliser une formule pour déterminer...
-On définit le format à appliquer si la condition est vraie (coloration jaune de la cellule, mais on peut choisir ce qu'on veut...)
-On ouvre la zone d'insertion de formule et on tape la formule conditionnelle :
=NB.SI(Feuil2!$A$2:$A$184;$A2)>0
(une formule conditionnelle de MFC ressemble à une formule utilisant une fonction SI, mais dont les éléments ValeurSiVrai et ValeurSiFaux sont laissés de côté (Excel s'en occupe en appliquant ou non la MFC), on ne formule que la condition qui renverra VRAI ou FAUX, et on n'utilise pas non plus le SI qui est alors sans utilité).

Cordialement.
JYW_MFC 2 feuilles.xlsx
(21.01 Kio) Téléchargé 5 fois
J
JYW
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 8 décembre 2018
Version d'Excel : 2016

Message par JYW » 11 décembre 2018, 13:44

Merci beaucoup MFerrand !
J’ai pu le transposer sur mon fichier et ça fonctionne parfaitement. C’est exactement ce dont j’avais besoin.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message