Formule somme.si.ens

Y compris Power BI, Power Query et toute autre question en lien avec Excel
H
Hubert78
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 9 octobre 2018
Version d'Excel : 2016

Message par Hubert78 » 9 octobre 2018, 13:49

Classeur1.xlsx
(13.69 Kio) Téléchargé 10 fois
Bonjour
je suis nouveau sur le forum je vous remercie bien pour l'aide que vous m'apporterez.
du fait que je ne trouve pas la réponse à ma question sur les FAQ, je me lance en vous demandant votre aide .
j'ai besoin de caluler la somme d'une colonne en fonction de 3 critères différents, j'ai essayer avec Somme.SI.ENS mais il semble que nous ne puissions dépasser 2 critères! et avec somme prod je n'y arrive pas non plus.
je vous joins un petit fichier en exemple!
Ps désolé je ne suis pas un grand pro des formules excel et encore moins les VBA
Classeur1.xlsx
(13.69 Kio) Téléchargé 10 fois
Merci
Hubert
Avatar du membre
Ausecour
Passionné d'Excel
Passionné d'Excel
Messages : 3'118
Appréciations reçues : 346
Inscrit le : 31 mai 2018
Version d'Excel : 2010 FR, 2013 FR

Message par Ausecour » 9 octobre 2018, 14:00

Bonjour et bienvenue sur le forum :)

J'ai tout d'abord une question à poser, vous souhaitez faire la somme des pommes et tomates en fonctions des numéros, cela veut dire que vous avez mis en critère le numéro, pomme, et tomate? Si c'est le cas c'est normal que rien ne fonctionne, si vous renseignez en critère tomate, et pomme, alors vous aurez 0, car aucune ligne ne contiendra pomme ET tomate, soit l'un, soit l'autre, il semble que vous voulez synthétiser vos données, connaissez vous les tableaux croisés dynamiques? Derrière ce nom complexe se cache un outil très simple qui permet de synthétiser rapidement les données, en voici un exemple :
Copie de Classeur1.xlsx
(12.54 Kio) Téléchargé 5 fois
On voit ici que l'on a 18 articles en référence 10, dont 18 pommes et 0 tomates
Que parmis ces 18 articles on a 15 pour DUPONT et 3 pour DURAND, etc etc...
Merci de me dire si cette solution vous intéresse :wink:
Plus un sujet a un titre précis, des explications claires, et un fichier Excel bien préparé, plus il a de chances d'avoir une réponse qui répond au besoin, mettez toutes les chances de votre côté :bien:
"100% des gagnants auront tenté leur chance" :trfl:
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 2'316
Appréciations reçues : 263
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 9 octobre 2018, 14:08

Bonjour Hubert78, le forum,

Un exemple.....
Copie de Classeur1.xlsx
(10.7 Kio) Téléchargé 6 fois
Cordialement
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 9 octobre 2018, 14:08

Bonjour le forum,

=SOMMEPROD((D3:D9={"Pomme"."Tomate"})*(C3:C9=H3)*(E3:E9))
Fruits.png
Fruits.png (12.6 Kio) Vu 98 fois
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 9 octobre 2018, 14:11

Bonjour,

Pour te donner une piste avec SommeProd() :
=SOMMEPROD((D3:D9="POMME")*1;(C3:C9="DURAND")*1;(B3:B9=10)*1;E3:E9)
la somme sera effectuée sur les cellules de la colonne E (E3:E9) avec les conditions que sur la même ligne se trouve "POMME" en colonne D, "DURAND" en colonne C et 10 en colonne B !
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 9 octobre 2018, 14:13

Hello mbbp (°v°)°

Bien vu, effectivement, j'ai oublié les constantes matricielles :(
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
H
Hubert78
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 9 octobre 2018
Version d'Excel : 2016

Message par Hubert78 » 9 octobre 2018, 14:41

Bonjour à tous
et merci pour votre réactivité.
je souhaitai effectivement arrivé à ce résultat:
pomme tomate
10 DUPONT 15 0
je comprends maintenant pourquoi cela ne focntionne pas en sommeprod..

et je voulais éviter de passer par le TDC et je vais m'y résoudre

encore grand merci à vous
bonne journée
Avatar du membre
Ausecour
Passionné d'Excel
Passionné d'Excel
Messages : 3'118
Appréciations reçues : 346
Inscrit le : 31 mai 2018
Version d'Excel : 2010 FR, 2013 FR

Message par Ausecour » 9 octobre 2018, 14:52

Bonjour,

Pourquoi vouloir éviter cet outil pourtant bien pratique? ::~
C'est super adapté à ton besoin à mon avis, tu peux ajouter du détail quand tu veux, changer son affichage, revoir la façon dont les données sont affichées, en quelques clics, très pratique aussi pour faire des graphiques ;;)

Si tu as des soucis sur son utilisation n'hésite pas :wink:
Plus un sujet a un titre précis, des explications claires, et un fichier Excel bien préparé, plus il a de chances d'avoir une réponse qui répond au besoin, mettez toutes les chances de votre côté :bien:
"100% des gagnants auront tenté leur chance" :trfl:
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 9 octobre 2018, 15:59

bonjour
une contribution à la tulipe
hubert.xlsx
(9.87 Kio) Téléchargé 4 fois
cordialement
c'est en cherchant qu'on trouve
H
Hubert78
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 9 octobre 2018
Version d'Excel : 2016

Message par Hubert78 » 9 octobre 2018, 16:30

Encore merci pour vos réponses et votre aide
j'ai réussi à faire ce que je souhaitai, alors peut-être aussi avais-je mal exprimé mes besoins, désolé.

en copie le tableau et si cela peut aussi aider quelqu'un j'en serai ravi.
@ Ausecour
même si le résultat sera identique rapport au TDC, mais je préfére une présentation avec choix sur une liste pour mes lecteurs qui semble pour une lecture plus facile
encore merci pour ton aide éclairé ;;)
Copie de hubert.xlsx
(15.9 Kio) Téléchargé 5 fois
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message