Extraire mot dans cellule

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
Clingn
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 21 septembre 2018
Version d'Excel : 2013 EN

Message par Clingn » 21 septembre 2018, 21:08

Bonjour,

Par avance je vous prie de m'excuser de ne pas avoir les accents, j'ai un claviers QWERTY.

J'essaye desesperement de resoudre mon souci. :(

J'ai une liste qui ressemble a ca

Dupont/1208/HOTEL
DUBOIS_1608_VOITURE
Duchamps VOITURE
DUJARDIN/8602_HOTEL

Et j'aimerai extraire uniquement les noms de famille de cette liste. Auriez-vous une solution ? Pour information j'ai une liste des noms de famille

Merci beaucoup par avance de votre aide :)

Oriane
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'689
Appréciations reçues : 647
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 21 septembre 2018, 21:32

Bonjour Oriane,

:bv:

je te propose ce fichier Excel :
Exo Oriane.xlsx
(9.07 Kio) Téléchargé 6 fois
merci de me dire si ça te convient.

dhany  Image
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 21 septembre 2018, 21:43

Bonsoir le forum,

=SIERREUR(SIERREUR(GAUCHE(A2;CHERCHE("/";A2;1)-1);GAUCHE(A2;CHERCHE(" ";A2;1)-1));GAUCHE(A2;CHERCHE("_";A2;1)-1))
C
Clingn
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 21 septembre 2018
Version d'Excel : 2013 EN

Message par Clingn » 21 septembre 2018, 23:05

Merci beaucoup de votre aide, j'ai pu traiter les 2/3 du fichier.

Cependant pour l'autre parti, le modele des cellules est aleatoire. Pensez-vous que ca pourrait exister une fonction qui cherche dans chaque cellule si les noms d'une liste n'y sont pas present et si un nom est present, qu'ils le ressortent ?

Je ne sais pas si je suis claire mais si j'ai une cellule

128653-CCC-DUBOIS18

Que la fonction regarde dans la liste que je lui ai donne de nom genre

DURAND
DUBOIS
DUMONT

Que la fonction voit que DURAND n'y ai pas mais voit que DUBOIS y est et me ressorte : DUBOIS ?

Sinon je me debroillerai manuellement pour le tiers restant :)
-> C'est un fichier rempli manuellement sur un logiciel et le remplissage des cellules est donc plutot aleatoire (mais le nom est toujours present).


Merci encore de vos reponses.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 21 septembre 2018, 23:44

Re,

=SI(NB.SI(B2;"*"&$A$2&"*")=1;$A$2;SI(NB.SI(B2;"*"&$A$3&"*")=1;$A$3;SI(NB.SI(B2;"*"&$A$4&"*")=1;$A$4;"")))
NOMS.png
NOMS.png (6.04 Kio) Vu 146 fois
C
Clingn
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 21 septembre 2018
Version d'Excel : 2013 EN

Message par Clingn » 24 septembre 2018, 16:11

Merci beaucoup mbbp !

Derniere petite question : pourrais tu me dire comment comment je fais pour rajouter d'autre nom, car ta formule est pour seulement 3 noms ?

Merci encore d'avance
C
Clingn
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 21 septembre 2018
Version d'Excel : 2013 EN

Message par Clingn » 24 septembre 2018, 16:28

En fait j'ai trouve ce qu'il fallait repeter mais cette formule ne marche malheureusement que pour 66 noms et j'en ai 76. Vous n'auriez pas une idee pour solutionner cela :( ?

Merci d'avance
Avatar du membre
Pedro22
Membre impliqué
Membre impliqué
Messages : 2'569
Appréciations reçues : 257
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 24 septembre 2018, 17:11

Bonjour,

Ce sujet pourra peut-être t'aider :
viewtopic.php?f=2&t=112628&p=673805&hil ... us#p673805
Le problème n'est pas de ne pas savoir, le problème est de ne pas chercher...
Ton problème est résolu ? N'oublie pas de l'indiquer :
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message