NB.SI et contient référence dans une autre cellule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
C
Cdricg
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 14 septembre 2018
Version d'Excel : 2007

Message par Cdricg » 14 septembre 2018, 13:49

Bonjour à chacun

Je pense que la question a déjà été abordée, je ne dois pas être le seul à avoir tenté la manip.
Peut-être que je n'utilise pas les bons termes pour la recherche...

je souhaiterais afficher dans la cellule A3 le nombre de cellules sur la Feuil1 qui contiennent la valeur texte contenue dans A2

voici ma formule dans la cellule A3 :
=NB.SI(Feuil1!FW2:Feuil1!FW83;"*A2*")

La formule :
=NB.SI(Feuil1!FW2:Feuil1!FW83;"*Prenom*")
fonctionne, mais le but est de ne pas avoir à réécrire chaque fois le prénom différent (j'ai une dizaine de lignes de statistiques qui suivent : les garçons qui s'appellent Roger et qui ont moins de 10 ans, par exemple)

En vous remerciant d'avance
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 5'613
Appréciations reçues : 422
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 14 septembre 2018, 13:51

Bonjour
=NB.SI(Feuil1!$FW$2:$FW$83;"*"&A2&"*")
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
C
Cdricg
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 14 septembre 2018
Version d'Excel : 2007

Message par Cdricg » 14 septembre 2018, 13:56

Merci beaucoup !
J'en étais à :
=NB.SI(Feuil1!$FW$2:$FW$83;"*&A2&*")

manquait donc des guillemets

encore merci
B
Braters
Membre dévoué
Membre dévoué
Messages : 579
Appréciations reçues : 10
Inscrit le : 23 décembre 2015
Version d'Excel : 2013 FR

Message par Braters » 14 septembre 2018, 14:07

Bonjour,

Tu n'étais pas loin, essaye donc comme ceci :
=NB.SI(Feuil1!$FW$2:$FW$83;"*" & A2 & "*")
A plus !
:btres:
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message