Somme : Inclure des cellules d'une colonne suivant données autre colonne

Bonjour a tous,

Voici mon probleme suivant la colonne A (option choisie avec un X ou autre) j'aimerai comptabiliser le prix de l'option dans le total de la colonne C.

Ex :

Option choisie

A B C

X Option 1 1 000,00 €

Option 2 1 500,00 €

X Option 3 600 €

total 1600

Merci d'avance pour votre aide.

Nico

bonjour

joindre un fichier

ajouter une colonne = SI(lacaseestcochée;mavaleur;0)

faire la somme de la colonne

Bonjour et merci pour votre réponse ,

J'ai trouvé ma réponse avec la formule

=SUMPRODUCT((C1:C10)*(A1:A10=E1))

Mais maintenant j'ai du texte dans ma colonne C que j'aimerais ne pas compter afin de ne pas créer d'erreur dans le calcu l(#value)

Est ce que vous auriez une idée (j'en suis sur )

Merci d'avance

Nico

13book2.xlsx (9.50 Ko)

bonjour

avec une colonne de pointage ou de traitement comme PJ

Mieux :

la formule pourrait être remplacée par un TCD : il n'y aurait alors besoin d'aucune formule

il serait peut-être possible de bricoler directement dans la formule, mais elle deviendrait illisible : pas bon si on veut un jour la modifier

note : "mettre sous forme de Tableau" est une condition pour bien travailler avec des tables de données

11copie-de-book2.xlsx (11.98 Ko)

Bonjour @ tous,

Sans colonne intermédiaire :

=SOMMEPROD((A1:A10=E1)*ESTNUM(C1:C10);C1:C10)

Cordialement

Bonjour,

Nul besoin de colonne supplémentaire (hormis Choix).

Les données sont sous forme de tableau et on utilise la fonction SOMME.SI()

Cdlt.

5book2.xlsx (15.98 Ko)
snip 20180829175503

Bonsoir le forum,

Supprimé

Super; merci a tous pour vos réponses !

Rechercher des sujets similaires à "somme inclure colonne suivant donnees"