Somme : Inclure des cellules d'une colonne suivant données autre colonne

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
N
Niwatts
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 28 août 2018
Version d'Excel : 2016

Message par Niwatts » 28 août 2018, 11:56

Bonjour a tous,

Voici mon probleme suivant la colonne A (option choisie avec un X ou autre) j'aimerai comptabiliser le prix de l'option dans le total de la colonne C.

Ex :
Option choisie
A B C
X Option 1 1 000,00 €
Option 2 1 500,00 €
X Option 3 600 €
total 1600

Merci d'avance pour votre aide.

Nico
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 28 août 2018, 12:03

bonjour

joindre un fichier

ajouter une colonne = SI(lacaseestcochée;mavaleur;0)
faire la somme de la colonne
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
N
Niwatts
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 28 août 2018
Version d'Excel : 2016

Message par Niwatts » 29 août 2018, 11:15

Bonjour et merci pour votre réponse ,

J'ai trouvé ma réponse avec la formule

=SUMPRODUCT((C1:C10)*(A1:A10=E1))

Mais maintenant j'ai du texte dans ma colonne C que j'aimerais ne pas compter afin de ne pas créer d'erreur dans le calcu l(#value)

Est ce que vous auriez une idée (j'en suis sur :mrgreen: )

Merci d'avance

Nico
Book2.xlsx
(9.5 Kio) Téléchargé 13 fois
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 29 août 2018, 17:29

bonjour

avec une colonne de pointage ou de traitement comme PJ
Mieux :
la formule pourrait être remplacée par un TCD : il n'y aurait alors besoin d'aucune formule

il serait peut-être possible de bricoler directement dans la formule, mais elle deviendrait illisible : pas bon si on veut un jour la modifier

note : "mettre sous forme de Tableau" est une condition pour bien travailler avec des tables de données
Copie de Book2.xlsx
(11.98 Kio) Téléchargé 11 fois
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 29 août 2018, 17:47

Bonjour @ tous,
:bv:
Sans colonne intermédiaire :
=SOMMEPROD((A1:A10=E1)*ESTNUM(C1:C10);C1:C10)

Cordialement
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'701
Appréciations reçues : 701
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 29 août 2018, 18:01

Bonjour,
Nul besoin de colonne supplémentaire (hormis Choix).
Les données sont sous forme de tableau et on utilise la fonction SOMME.SI()
Cdlt.
Book2.xlsx
(15.98 Kio) Téléchargé 5 fois
snip_20180829175503.png
snip_20180829175503.png (17.33 Kio) Vu 208 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 29 août 2018, 20:59

Bonsoir le forum,

Supprimé
N
Niwatts
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 28 août 2018
Version d'Excel : 2016

Message par Niwatts » 30 août 2018, 08:56

Super; merci a tous pour vos réponses ! ;;)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message