Compter des dates Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
E
Elendir
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 3 novembre 2015
Version d'Excel : 2007 FR

Message par Elendir » 26 août 2018, 12:44

Bonjour à toutes et tous

Je me heurte à un problème qui va paraitre simple à certains, mais que je n'arrive pas à résoudre
J'ai une feuille excel avec des dates exprimées ainsi

02/05/2000
01/01/1999
08/07/2000
03/02/2001
05/05/2000
02/01/1995

Et ainsi de suite
Quelle fonction dois-je utiliser pour qu'excel puisse me rendre un résultat
1995 : 1
1999 : 1
2000 : 3
2001 : 1

Je n'ai pas besoin de faire de macro : je n'ai que 15 années au total, mais comme cela tourne sur 106000 valeurs il m'est difficile de simpelment faire un classement puis compter manuellement (faisable mais long et peu élégant)

En vous remerciant d'avance,
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 26 août 2018, 12:49

Bonjour,

C'est faisable avec une matricielle du type
{=SOMME(((ANNEE(B2:B7)=1995)*1))}
Tu remplaces 1995 par la cellule qui contient l'année à tester et tu remplaces B2:B7 par la plage qui contient tes dates.

:btres:
Formateur bureautique, certifié ECDL Expert
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'392
Appréciations reçues : 241
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 août 2018, 12:50

Bonjour le forum,

Sans matricielle :

=SOMMEPROD(--(ANNEE($A$1:$A$7)=B2))
Années.png
Années.png (6.28 Kio) Vu 154 fois
Modifié en dernier par mbbp le 26 août 2018, 12:52, modifié 1 fois.
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 26 août 2018, 12:51

Il faudrait faire un bench, mais SOMMEPROD sera surement plus rapide que la matricielle. !
Formateur bureautique, certifié ECDL Expert
E
Elendir
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 3 novembre 2015
Version d'Excel : 2007 FR

Message par Elendir » 26 août 2018, 13:04

Merci à tous les 2 pour vos réponses
J'ai testé la version SOMMEPROD et effectivement ça a marché en 1 min

Un grand merci pour le coup de main, je me la note dans un coin pour les prochaines fois

je mets en "résolu"

:)
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'229
Appréciations reçues : 307
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 26 août 2018, 15:04

Bonjour à tous

C'est très long 1mn dans Excel...
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
E
Elendir
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 3 novembre 2015
Version d'Excel : 2007 FR

Message par Elendir » 26 août 2018, 15:49

M'en servant 15 min par jour, cela ne me pose aucun soucis
Mais je peux comprendre que certains aient besoin de fonction + automatisées
Comme ce n'est pas mon cas, la sommeprod fait parfaitement l'affaire
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 26 août 2018, 16:59

Je pense que quand il dit 'ça prend 1 minute', c'est une expression, car je viens de faire le test sur 1 000 000 de lignes et le résultat s'affiche en moins d'une seconde dans les deux cas !

SOMMEPROD ou Matricielle
Formateur bureautique, certifié ECDL Expert
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 26 août 2018, 16:59

:btres:
Formateur bureautique, certifié ECDL Expert
E
Elendir
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 3 novembre 2015
Version d'Excel : 2007 FR

Message par Elendir » 26 août 2018, 17:52

J'ai cliqué sur résolu il y a déjà 4h environ :wink:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message