comparer des cellules contenant une combinaison avec repetitions

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
mickaeldu45
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 mai 2018
Version d'Excel : 2016 FR

Message par mickaeldu45 » 18 mai 2018, 21:30

Bonjour tout le monde,

Je souhaite vérifier des conditions dans une combinaison avec répétitions, le mieux est de regarder le fichier joint pour mieux comprendre. Ma question est la suivante pouvez vous m'aidez à comparer ces valeurs.
combinaison.xlsx
(9.5 Kio) Téléchargé 11 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 18 mai 2018, 22:01

Bonjour
SI L'UNE DES COMBINAISON OK EST VERIFIE ALORS F10 AFFICHE VRAI
Oui! et comment est-elle vérifiée?
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
m
mickaeldu45
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 mai 2018
Version d'Excel : 2016 FR

Message par mickaeldu45 » 18 mai 2018, 22:13

J'ai essayé plusieurs chose :

En admettant que mes combinaisons soit saisie respectivement dans les cellules D1 D2 D3 D4 j'ai essayé cette formule dans F10 : =D1&D1&D1&D1<>$D$1&$D$2&$D$3&$D$4 mais cela ne me permet pas de vérifier toutes les combinaisons possibles, je ne dois pas avoir les 3 valeurs identiques, ais toutes les autres combinaisons conviennent.
J'ai aussi essayer D1<>D2;D2<>D3;D3<>D4;D1<>D4 mais c'est pareil les conditions ne sont pas respecter.

Cordialement
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 18 mai 2018, 22:26

Bonjour
Au vu des combinaisons
=SOMMEPROD(N($A$2:$A$36="AAA,BBB,CCC,DDD")*(B2:B36="OK"))=1
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
m
mickaeldu45
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 mai 2018
Version d'Excel : 2016 FR

Message par mickaeldu45 » 19 mai 2018, 08:01

Pour bien se comprendre, je joint une capture d'écran avec une explication de ce que je désire :
Sans titre.png
Alors la cellule A23 est celle qui dois afficher une valeur si toutes mes conditions sont réunies : =SI(ET(J4<>"";J4<>"Neutre";D24<>"";D25<>"";D26<>"";D27<>"";D24="FRANCE";D25="FRANCE";D26="FRANCE";D27="FRANCE";L24<>"";L25<>"";L26<>"";L27<>"";POUR CETTE PARTIE DE FORMULE VOIRE LA PROCHAINE CAPTURE D'ECRAN;Q24="Obtenu";Q25="Obtenu";Q26="Obtenu";Q27="Obtenu";A16="Double Champion");"Triple Champion";"")

POUR CETTE PARTIE DE FORMULE VOIRE LA PROCHAINE CAPTURE D'ECRAN :
Sans titre1.png
Sans titre1.png (5.38 Kio) Vu 205 fois
c'est donc ici que je bloque, pour que A23 affiche Triple Champion je dois vérifier que J4 n'est pas vide et que J4 est différent de Neutre et que D24 D25 D26 D27 n'est pas vide et que D24 D25 D26 D27 est égal à FRANCE et que L24 L25 L26 L27 n'est pas vide et L24 L25 L26 L27 dois contenir l'une des combinaison présente dans la copie d'écran juste au dessus et que Q24 Q25 Q26 Q27 est égal à Obtenu et que A16 est égal à Double Champion

L24 L25 L26 L27 dois contenir l'une des combinaison présente dans la copie d'écran juste au dessusgrâce à cela je vérifie que j'ai bien 4 certificat Obtenu en FRANCE avec 3 juges différents.

J'espère que la tout est claire j'ai fait de mon mieux pour expliquer

Cordialement
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'612
Appréciations reçues : 296
Inscrit le : 16 juin 2013
Version d'Excel : 2013 UK Windows 10

Message par h2so4 » 19 mai 2018, 10:57

Bonjour,

une solution possible basée sur ton premier fichier.
combinaison.xlsx
(9.86 Kio) Téléchargé 4 fois
m
mickaeldu45
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 mai 2018
Version d'Excel : 2016 FR

Message par mickaeldu45 » 19 mai 2018, 11:03

Merci h2so4 mais est t'il possible de l'inclure dans ma formule?
h2so4 a écrit :
19 mai 2018, 10:57
Bonjour,

une solution possible basée sur ton premier fichier.
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'612
Appréciations reçues : 296
Inscrit le : 16 juin 2013
Version d'Excel : 2013 UK Windows 10

Message par h2so4 » 19 mai 2018, 12:30

Bonjour


bonjour, si tu ne sais pas intégrer la formule, passe par des formules intermédiaires dans des cellules intermédiaires.
sinon c'est toujours mieux de mettre un fichier excel en lieu et place de photos dont on ne peut rien faire.
m
mickaeldu45
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 mai 2018
Version d'Excel : 2016 FR

Message par mickaeldu45 » 19 mai 2018, 12:42

Bonjour,

J'ai mis mon fichier en PJ

Cordialement
h2so4 a écrit :
19 mai 2018, 12:30
Bonjour


bonjour, si tu ne sais pas intégrer la formule, passe par des formules intermédiaires dans des cellules intermédiaires.
sinon c'est toujours mieux de mettre un fichier excel en lieu et place de photos dont on ne peut rien faire.
Classeur1.xlsx
(39.16 Kio) Téléchargé 4 fois
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'710
Appréciations reçues : 649
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 19 mai 2018, 12:45

@h2so4
Tu a écrit :si tu ne sais pas intégrer la formule, passe par des formules intermédiaires dans des cellules intermédiaires.
oui, mais l'ennui, c'est que plus y'a d'intermédiaires, plus on paye de TVA !  ::( :cry:

dhany
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message