si contient alors soustraire Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
seb92110
Jeune membre
Jeune membre
Messages : 32
Inscrit le : 3 mars 2014
Version d'Excel : 2007 FR

Message par seb92110 » 15 mai 2018, 16:10

Bonjour,

J'essaie de réaliser une formule si contient alors soustraire mais à chaque fois que je l'applique cela ne fonctionne pas comme je veux.
Je souhaiterais faire si la cellule C1 (par exemple) contient un chiffre finissant par 2 alors dans la cellule H1 enlever 1 à ce chiffre.

J'ai réalisé la formule suivante SI(DROITE(C1;1)=2;C1-1;C1), mais je n'obtiens pas mon résultat souhaité.

A chaque fois la formule me recopie la cellule C1.

Merci pour votre aide.
Seb92110
test.xlsx
(8.32 Kio) Téléchargé 3 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'376
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 15 mai 2018, 16:25

Bonjour le forum,

=SI(--DROITE(C1;1)=2;C1-1;C1)
1 membre du forum aime ce message.
Avatar du membre
teten1
Membre fidèle
Membre fidèle
Messages : 311
Appréciations reçues : 13
Inscrit le : 13 avril 2016
Version d'Excel : 2010

Message par teten1 » 15 mai 2018, 16:28

Bonjour,
Tu as oublié les guillemets sur le 2...
SI(DROITE(C1;1)="2";C1-1;C1)
christelle
Avatar du membre
teten1
Membre fidèle
Membre fidèle
Messages : 311
Appréciations reçues : 13
Inscrit le : 13 avril 2016
Version d'Excel : 2010

Message par teten1 » 15 mai 2018, 16:36

mbbp a écrit :
15 mai 2018, 16:25
Bonjour le forum,

=SI(--DROITE(C1;1)=2;C1-1;C1)
Bonjour mbbp...
c'est quoi cette petite astuce 8[]
christelle
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'376
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 15 mai 2018, 16:42

Bonjour teten1,

-- donne le même résultat que *1

=SI(DROITE(C1;1)*1=2;C1-1;C1)
s
seb92110
Jeune membre
Jeune membre
Messages : 32
Inscrit le : 3 mars 2014
Version d'Excel : 2007 FR

Message par seb92110 » 16 mai 2018, 09:43

Merci pour votre aide.

J'ai modifié la formule et ce la fonctionne très bien.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message