Remplir colonne auto en fonction d'une autre Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
L
Lunaïe
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 6 décembre 2016
Version d'Excel : 2007 FR

Message par Lunaïe » 17 avril 2018, 11:03

Bonjour mesdames messieurs,

Après plusieurs recherches infructueuses ou échec d'application de mes recherches je me tourne vers vous.

Je dois remplir dans un tableur une colonne "I" en fonction de la valeur de la colonne "J". La colonne "I" aura toujours pour valeur "Oui" ou "Non" en fonction de l'information en colonne "J". Exemple pour "Changement de direction" en "J" la valeur de "I" sera "Non", pour "Validation" la valeur sera "Oui", les informations sont multiples mais je pense qu'à partir d'un exemple pour ces deux-ci dessus je pourrai cette fois réussir à mettre en application pour les autres informations.
La ligne 1 comporte plusieurs titres de A1 à K1.

Je ne peux malheureusement pas mettre l'exemple à proprement dit sur le forum, si besoin je pourrai en refaire un avec des données bateaux.

Vous remerciant par avance.

Cordialement.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 17 avril 2018, 11:35

Bonjour le forum,
Lunaïe a écrit :
17 avril 2018, 11:03
les informations sont multiples mais je pense qu'à partir d'un exemple pour ces deux-ci dessus je pourrai cette fois réussir à mettre en application pour les autres informations.
Faire la liste des "informations" qui impliquent une réponse OUI.
Nommer cette liste (liste1 par ex)

I2 :
=SI(NB.SI(J2;liste1)=1;"Oui";"Non")
L
Lunaïe
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 6 décembre 2016
Version d'Excel : 2007 FR

Message par Lunaïe » 17 avril 2018, 11:52

Merci Mbbp pour ta réponse,

Je suis un peu, voir complétement rouillé avec exel je n'y ai pas touché depuis 10 ans, d'où mes échecs cuisant sur mes tentatives, et d'où ma question suivante:

J'ai bien essayé de faire une liste avec menu déroulant sur la colonne "J" mais du coup je doute que ce soit ce genre de liste dont tu me parles, peux être veux tu dire sur une autre feuille du classeur qui s'appelera donc liste1 et que la formule ira chercher sur cette page?

Cordialement.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 17 avril 2018, 12:31

Re,

La liste peut être sur la même feuille ou sur une autre.

Rectification de la formule proposée :
=SI(NB.SI(liste1;J2)=1;"Oui";"Non")
L
Lunaïe
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 6 décembre 2016
Version d'Excel : 2007 FR

Message par Lunaïe » 17 avril 2018, 12:49

Ok merci, impeccable ça me donne ce que je veux niquel. Merci pour ton aide ;-).

Bonne continuation.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message