Sommeprod ou somme.si.ens

Bonjour les amis,

J'ai réussi à utiliser la fonction sommeprod jusqu'à une certaine ligne (ligne 24) et comme le tableau est vide en dessous de la ligne 24, le calcul renvoi une erreur. J'aimerai que la fonction sommeprod soit utiliser jusqu'à la 1000ème ligne même s'il y a des lignes vides.

Il existe peut-être une autre fonction (SOMME.SI.ENS).

Pouvez-vous m'aider svp ?

Fichier joint

Bonjour à mettre en C5 ou E5 et a glisser jusqu'où tu veux :

=SOMME.SI.ENS($X:$X;$S:$S;B$3;$Q:$Q;$A5)

Bonjour,

Ou bien en remplissant les cellules vides des colonnes X et Y avec des 0

Cordialement

Merci bigdaddy pour ta réactivité, par contre j'ai essayé et cela ne fonctionne pas.

Peux tu le faire sur mon fichier que j'ai joins pour mieux comprendre ?

Merci Dug59,

Sa fonctionne parfaitement, merci encore

Cordialement

Pour moi cela fonctionne Miloud,

ton fichier en retour.

Effectivement cela fonctionne aussi, autant pour moi, j'ai du faire une mauvaise manipulation. Par contre, dans ta formule, il ne prend en compte que le débit (dépense) et il ne soustrais pas le crédit (recette).

Merci encore

Effectivement :

=SOMME.SI.ENS($X:$X;$S:$S;B$3;$Q:$Q;$A5)-SOMME.SI.ENS($Y:$Y;$S:$S;B$3;$Q:$Q;$A5)

Et tout devrait rentrer dans l'ordre

Bonjour,

Regarde une solution avec un TCD et un tableau Excel .Quand tu remplis ton tableau, une actualisation du TCd te donne tes resultats

Je te remercie DjiDji59430 mais je ne suis vraiment pas à l'aise avec les TCD, tant sur la compréhension que sur les présentations de tableaux...

Merci quand même

Rechercher des sujets similaires à "sommeprod somme ens"