Recherche formule

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
N
Nullenexcel
Jeune membre
Jeune membre
Messages : 43
Inscrit le : 16 août 2017
Version d'Excel : 2013

Message par Nullenexcel » 11 mars 2018, 15:38

Bonjour à tous,

J'espère que vous allez bien :)
Je viens solliciter votre aide, si vous le voulez bien of course ;;)

Alors, je suis à la recherche d'une formule qui me permettrait de calculer le nombre de lignes, selon la valeur d'une colonne.
Je ne sais pas si je suis claire, mais je vais essayer de vous expliquer ce que je veux.

Je vous ai fait un tableau brouillon qui reprend mon idée.
Dans la feuille 1, j'ai un grand tableau qui représente une liste d'objets avec leur couleur.
Sur la feuille 2, je veux compter le nombre d'objets que j'ai par couleur. J'aimerais donc une formule qui me compte ça automatiquement.

Je vous remercie par avance de votre aide,
Bien à vous :)
Exemple Excel Pratique.xlsx
(15.41 Kio) Téléchargé 7 fois
Exemple Excel Pratique.xlsx
(15.41 Kio) Téléchargé 7 fois
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 7'102
Appréciations reçues : 371
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 11 mars 2018, 15:56

Bonjour,

formule en C4 : =SOMMEPROD((Sheet1!$C$3:$C$11=Sheet2!$B4)*1)
SOMMEPROD est une formule matricielle, de ce fait elle est capable de tester plusieurs lignes sur une seule ligne de formule

Elle fait la "somme" des "produits", les produits qu'on lui demande sont :
dans la colonne allant de C3 à C11 vérifie si les valeurs sont égales à B4 de la feuille 2
si c'est VRAI excel considère 1, si c'est FAUX Excel considère 0, l'ensemble de ces résultats sont multipliés par 1
on obtient donc pour le test avec B4 une matrice de réponse :
1
1
1
1
1
0
0
0
0
Si on fait la somme de ces produits alors on obtient 5 pour le rouge
La formule décalée en ligne C pour le vert, on obtient :
0
0
0
0
0
1
1
1
1
la somme donne 4.
SOMMEPROD permet de faire la somme des produits en y intégrants des conditions... Le Top ! ;;)

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
N
Nullenexcel
Jeune membre
Jeune membre
Messages : 43
Inscrit le : 16 août 2017
Version d'Excel : 2013

Message par Nullenexcel » 11 mars 2018, 16:44

Magique !
Merci beaucoup LouReed, tu expliques super bien en plus :mrgreen: :mrgreen:
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 11 mars 2018, 16:51

Bonjour @ tous,
pourquoi faire simple quand on peut faire compliqué, en C4 :
=NB.SI(Sheet1!C$3:C$11;B4)
@ tirer vers le bas


Cordialement
"Donnez moi un point d'appui et je soulèverai le monde"
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 11 mars 2018, 18:01

bonjour
une contribution
nulle en excel.xlsx
(10.19 Kio) Téléchargé 4 fois
je l'ai mis sur la feuille 1 ,mais c'est pareil
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 11 mars 2018, 18:18

Re,
tulipe_4 a écrit :
11 mars 2018, 18:01
bonjour
une contribution
nulle en excel.xlsx
je l'ai mis sur la feuille 1 ,mais c'est pareil
cordialement
voir PJ
Tulipe_4.xlsx
(10.8 Kio) Téléchargé 7 fois
Cordialement
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 7'102
Appréciations reçues : 371
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 11 mars 2018, 19:42

Bonsoir R@chid, tulipe_4,
Bonjour @ tous,
pourquoi faire simple quand on peut faire compliqué
En fait c'est moi le "Null en Excel"... :(

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 11 mars 2018, 19:56

LouReeD a écrit :
11 mars 2018, 19:42
Bonsoir R@chid, tulipe_4,
Bonjour @ tous,
pourquoi faire simple quand on peut faire compliqué
En fait c'est moi le "Null en Excel"... :(

@ bientôt

LouReeD
bonsoir
et moi j'avais tablé sur le fait que la nature à horreur du vide :lol:
cordialement
c'est en cherchant qu'on trouve
N
Nullenexcel
Jeune membre
Jeune membre
Messages : 43
Inscrit le : 16 août 2017
Version d'Excel : 2013

Message par Nullenexcel » 12 mars 2018, 09:45

Bonjour,

Merci à vous pour vos réponses :)

@Rachid, merci pour la formule, beaucoup plus simple effectivement 8-)
@Tulipe, top ta formule en cas de doublons, je la garde précieusement :roll:

Merci encore et bonne journée !
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'121
Appréciations reçues : 33
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 12 mars 2018, 09:50

Bonjour tous,

un tcd et c'est fait :)

P.
Exemple Excel Pratique.xlsx
(14.31 Kio) Téléchargé 4 fois
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message