index/equiv/na

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Dug59
Membre fidèle
Membre fidèle
Messages : 260
Appréciations reçues : 22
Inscrit le : 18 décembre 2017
Version d'Excel : 2010 FR

Message par Dug59 » 21 février 2018, 16:18

Re,
Oui : vous écrivez le Equiv sans préciser le dernier argument qui est donc mis à 1 par défaut c'est à dire : renvoie de la dernière valeur inférieure à la recherche et non la valeur exactement identique (obtenue avec l'argument 0)
modifiez ainsi votre formule :
=INDEX('Données SAP'!D$5:D$706;EQUIV('Analyse assortiment'!$B3&"";'Données SAP'!$A$5:$A$706;0))

Du coup vous allez obtenir des #NA qui ne sont pas très seyants :)

avec :
=SIERREUR(INDEX('Données SAP'!D$5:D$706;EQUIV('Analyse assortiment'!$B3&"";'Données SAP'!$A$5:$A$706;0));"-")

vous afficherez des - à la place des erreurs
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Index Equiv
    par brunyon » 27 juin 2014, 21:44 » dans Excel - VBA
    3 Réponses
    199 Vues
    Dernier message par brunyon
    28 juin 2014, 21:02
  • Index Equiv
    par Botis » 23 octobre 2019, 15:17 » dans Excel - VBA
    6 Réponses
    72 Vues
    Dernier message par Botis
    23 octobre 2019, 18:32
  • Index, equiv
    par Username123 » 25 novembre 2019, 15:51 » dans Excel - VBA
    5 Réponses
    46 Vues
    Dernier message par Username123
    25 novembre 2019, 16:27
  • Index et Equiv
    par Philippe02 » 27 février 2017, 20:10 » dans Excel - VBA
    10 Réponses
    205 Vues
    Dernier message par tulipe_4
    1 mars 2017, 13:02
  • INDEX-EQUIV
    par lucie1206 » 25 octobre 2016, 14:41 » dans Excel - VBA
    5 Réponses
    222 Vues
    Dernier message par Steelson
    26 octobre 2016, 16:48
  • Index equiv
    par JP54 » 29 novembre 2019, 15:55 » dans Excel - VBA
    8 Réponses
    91 Vues
    Dernier message par JP54
    30 novembre 2019, 16:25