index/equiv/na

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Dug59
Membre fidèle
Membre fidèle
Messages : 259
Appréciations reçues : 22
Inscrit le : 18 décembre 2017
Version d'Excel : 2010 FR

Message par Dug59 » 21 février 2018, 16:18

Re,
Oui : vous écrivez le Equiv sans préciser le dernier argument qui est donc mis à 1 par défaut c'est à dire : renvoie de la dernière valeur inférieure à la recherche et non la valeur exactement identique (obtenue avec l'argument 0)
modifiez ainsi votre formule :
=INDEX('Données SAP'!D$5:D$706;EQUIV('Analyse assortiment'!$B3&"";'Données SAP'!$A$5:$A$706;0))

Du coup vous allez obtenir des #NA qui ne sont pas très seyants :)

avec :
=SIERREUR(INDEX('Données SAP'!D$5:D$706;EQUIV('Analyse assortiment'!$B3&"";'Données SAP'!$A$5:$A$706;0));"-")

vous afficherez des - à la place des erreurs
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Index Equiv
    par brunyon » 27 juin 2014, 21:44 » dans Excel - VBA
    3 Réponses
    209 Vues
    Dernier message par brunyon
    28 juin 2014, 21:02
  • Index/equiv ? #N/A
    par pika83 » 30 novembre 2019, 14:16 » dans Excel - VBA
    9 Réponses
    95 Vues
    Dernier message par xorsankukai
    30 novembre 2019, 17:09
  • Index et equiv
    par btazz34 » 28 avril 2019, 11:13 » dans Excel - VBA
    2 Réponses
    114 Vues
    Dernier message par btazz34
    28 avril 2019, 13:56
  • Index/ equiv
    par hem-id » 28 septembre 2017, 09:48 » dans Excel - VBA
    15 Réponses
    422 Vues
    Dernier message par hem-id
    30 septembre 2017, 12:04
  • Index et Equiv
    par Philippe02 » 27 février 2017, 20:10 » dans Excel - VBA
    10 Réponses
    360 Vues
    Dernier message par tulipe_4
    1 mars 2017, 13:02
  • INDEX + EQUIV
    par sophiane » 11 mars 2016, 14:43 » dans Excel - VBA
    51 Réponses
    1298 Vues
    Dernier message par sophiane
    24 mars 2016, 10:17