Moyenne automatique par mois excluant cellules vides ou 0 Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Moustik
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 10 février 2018
Version d'Excel : PC 2013 FR

Message par Moustik » 19 février 2018, 16:24

Bonjour à tous,

je rencontre un nouveau problème avec mon projet.

Je cherche à réaliser l'opération suivante : calculer une moyenne en pourcentage par mois d'après une série de valeurs en pourcentages courant sur plusieurs mois

Le fichier s'organise ainsi :
* Colonne A : dates au format jj/mm/aaaa
* Colonne B : pourcentage issu d'un autre calcul au format 2 chiffres et %

La formule que j'ai utilisée est la la suivante :
=SOMMEPROD((MOIS($A$3:$A$1000)=B1)*(B$3:$B$30))/SOMMEPROD((MOIS($A$3:$A$30)=B1)*($B$3:$B$30<>""))
avec B1 représentant le mois.

Je rencontre 2 soucis :
* la formule semble marcher pour le premier mois et avec des colonnes pleines
* la formule renvoit #DIV/0 pour les mois suivants alors que des données sont déjà disponibles (cellules non vides et non nulles)

Je joins un petit fichier, ce n'est pas celui sur lequel je travaille mais si cela peut aider à mieux cerner mon problème.

Merci par avance
test.xlsx
(8.77 Kio) Téléchargé 10 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 19 février 2018, 16:35

Bonjour le forum,

F3 :
=SIERREUR(SOMMEPROD((MOIS($A$2:$A$7)=MOIS(F1))*($B$2:$B$7))/SOMMEPROD((MOIS($A$2:$A$7)=MOIS(F1))*($B$2:$B$7<>""));"")
A tirer vers la droite.
Moyennes.png
Moyennes.png (10.95 Kio) Vu 203 fois
Avatar du membre
Moustik
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 10 février 2018
Version d'Excel : PC 2013 FR

Message par Moustik » 19 février 2018, 17:08

Bonjour mbbp,

j'ai appliqué et adatpée ta formule à mon classeur et celle-ci marche du tonnerre. J'ai encore un petit soucis avec le formatage de mes données (mes pourcentages de base sont issus d'une formule de différence et sèment la panique car le système les voit en 0% et non 0) mais pour tout le reste cela fonctionne à merveille.

Merci pour ta réactivité.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 19 février 2018, 17:14

Un extrait de ton fichier ...
Avatar du membre
Moustik
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 10 février 2018
Version d'Excel : PC 2013 FR

Message par Moustik » 19 février 2018, 17:18

Le voici
extrait.xlsx
(15.49 Kio) Téléchargé 7 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 19 février 2018, 20:49

Re,

Voir le fichier joint.
Moyennes.xlsx
(16.69 Kio) Téléchargé 11 fois
1 membre du forum aime ce message.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 19 février 2018, 21:15

Re,

Ou, avec une seule formule à tirer vers la droite ?
%.png
%.png (13.69 Kio) Vu 180 fois
Avatar du membre
Moustik
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 10 février 2018
Version d'Excel : PC 2013 FR

Message par Moustik » 19 février 2018, 21:58

Re,

ta première formule dans le fichier fourni marche très bien. Elle tient maintenant compte des 1000 lignes ainsi que des lignes vides.

Merci beaucoup pour ton aide.

PS : je cherche toujours à comprendre pourquoi le système ne valide pas le formatage de date alors qu'une formule similaire marche juste quelques lignes au-dessus.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 19 février 2018, 22:35

Merci pour ta réponse.

Une seule formule pour l'année à tirer vers le bas :

=SI(ESTTEXTE(A3);SOMMEPROD((MOIS($B$3:$B$30)=NBVAL($A$3:A3))*($P$3:$P$30))/SOMMEPROD((MOIS($B$3:$B$30)=NBVAL($A$3:A3))*($P$3:$P$30<>""));"")
Months.png
Months.png (12.85 Kio) Vu 171 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message