Somme cumulée en fonction de la catégorie et du rang

Bonjour à tous !

Je me permets de venir déposer mon problème sur ce forum qui ma déjà aidé de nombreuses fois car il faut avouer que cette communauté est vraiment active et compétente.

Voila mon problème, j'ai un tableau avec :

  • Des références de produits en colonne A
  • La catégorie de ces produits en colonne B
  • Le Chiffre d'affaire (CA) prévisionnel en C
  • Le rang par catégorie en D

Je cherche à faire dans ma colonne D une somme cumulée qui prendrait en compte le rang et la catégorie des produits (Cf fichier ci-joint)

Je vous remercie d'avance pour vos réponses

Bonne journée !

Buzz

25test-excel.xlsx (11.81 Ko)

Bonjour le forum,

E5 :

=SOMMEPROD(($B$5:B5=B5)*($C$5:C5))

A tirer vers le bas.

Bonjour,

Une proposition à étudier.

Cdlt.

24test-excel.xlsx (23.90 Ko)

Ou :

=SOMME.SI($B$5:B5;B5;$C$5:C5)

Super ça marche parfaitement, une SOMMEPROD suffisait, je doit être trop fatigué pour ne pas y avoir pensé

Vivement le weekend !

Merci à vous deux en tous cas

Bonne fin de journée

Buzz

Rechercher des sujets similaires à "somme cumulee fonction categorie rang"