NB.Si.ENS.SOMME.SI. .... Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
g
guigol
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 22 février 2013
Version d'Excel : Office 365

Message par guigol » 22 janvier 2018, 12:17

Bonjour,

Je m'y perds pourtant je sens que la solution n'est pas loin.

Voila un tableau tout simple. Avec des critères en colonne B et C.

J'aimerais pouvoir afficher le résultat en B6.
le but est de comptabiliser les lignes ou la somme est strictement supérieure à 1 (ici : C, D et E)

Je pourrais rajouter une colonne D et faire la somme de chaque ligne puis un NB.Si (">1") en bas, mais je trouve ca moins propre que de tout calculer d'un coup.

une idée?
Sans titre.png
Sans titre.png (2.88 Kio) Vu 106 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'453
Appréciations reçues : 428
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 janvier 2018, 12:34

bonjour

une proposition, formule à mettre en B6
=SOMMEPROD((((B1:B5)+(C1:C5))>1)*1)
1 membre du forum aime ce message.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 22 janvier 2018, 12:37

Bonjour le forum,

C'est la formule de h2s04 qui fonctionne, légèrement modifiée :
=SOMMEPROD((((B1:B5)+(C1:C5))>0)*1)
Modifié en dernier par mbbp le 22 janvier 2018, 12:50, modifié 1 fois.
g
guigol
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 22 février 2013
Version d'Excel : Office 365

Message par guigol » 22 janvier 2018, 12:41

Super. merci beaucoup.

Ca marche beaucoup mieux comme ca.
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'453
Appréciations reçues : 428
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 janvier 2018, 13:00

Bonjour,

j'ai mis >1 parce que j'ai compris que la somme devait être strictement supérieure à 1 ::o
g
guigol
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 22 février 2013
Version d'Excel : Office 365

Message par guigol » 22 janvier 2018, 13:05

Je confirme. Je souhaitais compter le nombre de ligne dont la somme est strictement supérieure à 1.
H2so4 avait raison.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 22 janvier 2018, 13:17

guigol a écrit :
22 janvier 2018, 13:05
Je confirme. Je souhaitais compter le nombre de ligne dont la somme est strictement supérieure à 1.
H2so4 avait raison.
Et je confirme également.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message