Extraire dernier mot cellule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
x
xnipec
Jeune membre
Jeune membre
Messages : 26
Inscrit le : 11 janvier 2013
Version d'Excel : 2010

Message par xnipec » 30 décembre 2017, 02:57

Bonjour à tous,
Pourriez vous nous aider à solutionner ce problème SVP?
Comment faire pour que la dernière ville ou mot de i2 apparaisse toujours en i3, si par exemple il n'y a pas d'étape 5 ou 4 et 5 ou 3, 4 et 5?
D'avance un énorme merci à tous ceux qui nous viennent en aide sur ce forum très pro.
Xni
extraire dernier mot.xlsx
(9.84 Kio) Téléchargé 25 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'041
Appréciations reçues : 830
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 30 décembre 2017, 03:54

Bonjour,

je mettrais ceci en I3
=INDEX(C3:G3;EQUIV("ZZZ";C3:G3;1))

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 décembre 2017, 10:34

Bonjour le forum,

Avec une modification de la formule en H3 :
=C3&" "&D3&SI(E3=0;"";"  "&E3&SI(F3=0;"";"  "&F3&SI(G3=0;"";"  "&G3)))
Une matricielle :
=SIERREUR(DROITE(H3;EQUIV(" ";STXT(H3;NBCAR(H3)-LIGNE(INDIRECT("1:"&NBCAR(H3)));1);0));C3)
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 30 décembre 2017, 10:43

Bonjour,

Pour la dernière colonne contenant une ville ...

ci-joint ton fichier ...

En espérant que cela t'aide ...
extraire dernier mot.xlsx
(9.62 Kio) Téléchargé 19 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 décembre 2017, 13:40

Une deuxième, non matricielle :
=SIERREUR(INDEX(A3:G3;1;SI(G3<>"";COLONNE(G3);SI(F3<>"";COLONNE(F3);SI(E3<>"";COLONNE(E3);SI(D3<>"";COLONNE(D3);SI(C3<>"";COLONNE(C3)))))));"")
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 30 décembre 2017, 14:34

Re,

Dans la même veine que Michel ... en I3 ... :wink:
=RECHERCHE(REPT("z";255);C3:G3)
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'041
Appréciations reçues : 830
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 30 décembre 2017, 15:10

Hello Bond, mbbp ...

bien vu le RECHERCHE, mieux que INDEX/EQUIV !

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 décembre 2017, 16:59

Salut Steelson,

Cellules C2:G2 au format : "Etape" 0
Saisir 1 à 5 dans ces cellules.
=INDEX(C3:G3;EQUIV((C3>0)+(D3>0)+(E3>0)+(F3>0)+(G3>0);C2:G2;0))
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'041
Appréciations reçues : 830
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 30 décembre 2017, 17:05

original !! je n'y avais pas pensé
1 membre du forum aime ce message.

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
x
xnipec
Jeune membre
Jeune membre
Messages : 26
Inscrit le : 11 janvier 2013
Version d'Excel : 2010

Message par xnipec » 30 décembre 2017, 17:10

Que dire...James, Mbbp et Steelson, si ce n'est mille mercis.
3 options qui fonctionnent, c'est Noël!! :lol:
Encore bravo
Xni
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message