Recherche de l'information sur une autre colonne, erreur

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
M
Maibber
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 17 décembre 2017
Version d'Excel : Excel 2007 en Français

Message par Maibber » 21 décembre 2017, 20:13

Bonjour à tous,

Désolée si le sujet a déjà été abordé, il me semblait avoir vu une discussion quelque part à ce propos mais impossible de la retrouver.
J'ai une liste d'actions à mettre en place et la personne devra choisir la semaine pour le démarrer.

Je voulais qu'automatiquement créer un planning à côté pour pouvoir l'imprimer.
J'essai avec la fonction RECHERCHEV. mais j’obtiens que des erreurs ou bien la cellule que je ne veux pas.
Je pense que c'est vraiment simple mais je n'arrive pas :(

Merci d'avance. cordialement,

Maria
Exemple planning problème.xlsx
(12.6 Kio) Téléchargé 5 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'453
Appréciations reçues : 428
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 21 décembre 2017, 20:19

Bonsoir,

une proposition

formule à mettre en H7 et à copier vers la bas
=INDEX($C$7:$C$9;EQUIV(G7;$E$7:$E$9;0))
lorsque tu veux faire un rechercheV, la première colonne de la plage doit être la colonne sur laquelle on fait la recherche. ici ta plage est B7:E9 et ta colonne de recherche est E. cas de figure incompatible avec rechercheV
M
Maibber
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 17 décembre 2017
Version d'Excel : Excel 2007 en Français

Message par Maibber » 21 décembre 2017, 23:50

Merci beaucoup,
C'est exactement cela que j'avais besoin. Par contre si il y a une semaine qu'une action n'est pas mise en place il affiche comme réponse #N/A.

Est-ce que c'est possible que la cellule soit vide?

Merci en tout cas.

Maria
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'453
Appréciations reçues : 428
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 décembre 2017, 00:02

Bonsoir,

voici la formule adaptée
=SIERREUR(INDEX($C$7:$C$9;EQUIV(G7;$E$7:$E$9;0));"")
M
Maibber
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 17 décembre 2017
Version d'Excel : Excel 2007 en Français

Message par Maibber » 22 décembre 2017, 08:27

Merci beaucoup!!!
et cliqué :)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message