Variable dans une formule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Baboune11
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 15 décembre 2017
Version d'Excel : 2007 FR

Message par Baboune11 » 15 décembre 2017, 15:28

Bonjour à tous,
Dans mon classeur, j'ai plusieurs feuilles que j'ai nommé E01, E02, E03, …
Sur une autre feuille (Récap), dans une cellule (A1), j'ai la formule : =SI(G9="";"";'E01'!I3)
Dans la cellule G9 (variable), je mets : E01 qui fait référence à la feuille E01.
J'obtiens donc le contenu de la cellule I3 de la feuille E01 dans la cellule (A1).
Je voudrai qu'en changeant le contenu de G9, par exemple E03, j'obtienne le contenu de la cellule I3 de la feuille E03.
La formule serait : =SI(G9="";"";'maVARIABLE'!I3)
maVARIABLE étant la valeur de G9
Faut-il passer par une macro ou quelle serait la fonction ?
Merci pour le coup de main, car j'y ai déjà passé quelques heures sur les sites.
Cordialement.
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 414
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 15 décembre 2017, 15:33

Bonjour,

La fonction Indirect() ... fera ton bonheur ... :wink:

A tester ...
=SI(G9="";"";INDIRECT("'"&G9&"'"&"!I3"))
En espérant t'épargner quelques autres heures de recherche .... :)
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Baboune11
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 15 décembre 2017
Version d'Excel : 2007 FR

Message par Baboune11 » 15 décembre 2017, 15:45

Merci James007 digne de Lucky Luke :cp1:

J'ai testé cette fonction et obtenu des "0" ou "#REF" ...

Celle-ci fonctionne à merveille, je n'avais pas su exploiter le "ref_texte" et le "&". :oops:

Merci pour ta rapidité : :)
Cordialement
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 414
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 15 décembre 2017, 15:52

Baboune11 a écrit :
15 décembre 2017, 15:45
Merci James007 digne de Lucky Luke :cp1:

J'ai testé cette fonction et obtenu des "0" ou "#REF" ...

Celle-ci fonctionne à merveille, je n'avais pas su exploiter le "ref_texte" et le "&". :oops:

Merci pour ta rapidité : :)
Cordialement
Content que cela puisse t'aider ...et t'épargner de longues heures de recherche ... :wink:


Merci pour tes remerciements ... ET pour la Coupe .... !!! :youhou: :¬OL:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Baboune11
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 15 décembre 2017
Version d'Excel : 2007 FR

Message par Baboune11 » 15 décembre 2017, 16:03

Re :

En fait les deux formules fonctionnent :

=SI(G9="";"";INDIRECT(G9&"!I3"))
=SI(G9="";"";INDIRECT("'"&G9&"'"&"!I3"))

Encore MERCI ! :)
@+
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 414
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 15 décembre 2017, 16:53

Re,

A vrai dire ... là où il faut être très attentif ... c'est par rapport au nom de l'onglet ...

Si ce dernier contient des espaces ... les apostrophes deviendront obligatoires ... ;;)

Bonne Continuation ...
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Baboune11
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 15 décembre 2017
Version d'Excel : 2007 FR

Message par Baboune11 » 15 décembre 2017, 17:07

Merci du conseil !

En effet, je fait toujours attention au nom des onglets, en évitant les espaces et en privilégiant un nom court.
Ici, j'ai opté pour l'initiale et un numéro ...

:sp:
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 414
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 15 décembre 2017, 17:18

Baboune11 a écrit :
15 décembre 2017, 17:07
Merci du conseil !

En effet, je fait toujours attention au nom des onglets, en évitant les espaces et en privilégiant un nom court.
Ici, j'ai opté pour l'initiale et un numéro ...

:sp:
De rien ... :wink:

Là je suis pas mal jaloux ...

Tu l'as posé où ... ton transat ... :secu:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Baboune11
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 15 décembre 2017
Version d'Excel : 2007 FR

Message par Baboune11 » 15 décembre 2017, 17:34

Mon transat c'est la campagne, près de la méditerranée, au alentour de Narbonne ... :)
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 414
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 15 décembre 2017, 18:54

Baboune11 a écrit :
15 décembre 2017, 17:34
Mon transat c'est la campagne, près de la méditerranée, au alentour de Narbonne ... :)
VEINARD ...

J'espère que tu en profites un MAX ...

8-) 8-) 8-)
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message