Fonction RANG ou classement avec deux critères Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
l
laglanne21
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 16 novembre 2017
Version d'Excel : 2013 FR

Message par laglanne21 » 9 décembre 2017, 12:23

Bonjour à tous

Un petit problème avec la fonction RANG

J'ai un fichier Excel qui comporte dans la colonne A les noms des élèves; en B les différentes classes (Sixième,cinquième....) et en C les notes .
Je voudrais utiliser une fonction RANG(Si possible) pour obtenir le rang de chaque élève par classe.

Je joins à mes propos ce fichier Exemple en pièce jointe.

Merci de me venir en aide
test rang.xlsx
(9.3 Kio) Téléchargé 203 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 9 décembre 2017, 13:20

Bonjour,
en D2 :
=NB.SI.ENS(B$2:B$9;B2;C$2:C$9;">="&C2)
@ tirer vers le bas

en cas d’exæquos, on fait quoi ?
merci de revenir avec un fichier plus explicite.

Cordialement
"Donnez moi un point d'appui et je soulèverai le monde"
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 9 décembre 2017, 13:32

Bonjour,

Autre version :
=SOMMEPROD(--($B$2:$B$9=B2)*($C$2:$C$9>=C2))-SOMMEPROD(--($B$2:$B$9=B2)*($C$2:$C$9=C2))+1
NB- La première expression fournit le rang "brut", mais en cas d'ex-aequo ce rang sera aligné sur l'inférieur (ex: si 2 2e ex-aequo, l'expression renverra 3). Le reste de la formule est un correctif pour rétablir le bon range des ex-aequo (dans l'exemple, cela rétablira le rang à 2, et si pas ex-aequo sur la note, le correctif vaut 0...)

Cordialement.
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'701
Appréciations reçues : 701
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 9 décembre 2017, 14:47

Bonjour à tous,
Et une solution TCD, une... :oops:
Cdlt.
test rang.xlsx
(33.92 Kio) Téléchargé 226 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message