Multiplier colonnes deux par deux et additionner les résulta Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
bl27
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 16 mars 2017
Version d'Excel : 2013

Message par bl27 » 27 novembre 2017, 17:17

Bonjour,

J'ai la très très longue formule =(B3-E3)*F3+(B3-G3)*H3+(B3-I3)*J3+(B3-K3)*L3+.......+(B3-Q50)*R50 et je me demandais si c'était techniquement possible de la simplifier.

J'ai essayé d'utiliser sommeprod mais je n'y suis pas parvenu vu que toutes les données se trouvent sur la même ligne.

Pour que ça soit plus clair, je joins un fichier test (voir la colonne C).

Je vous remercie par avance de votre aide.

BL
Test.xlsx
(11.95 Kio) Téléchargé 7 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 445
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 27 novembre 2017, 17:50

Bonsoir,

En C3 :
=SOMMEPROD((B3-D3:P3)*(MOD(COLONNE(D3:P3);2)=0);E3:Q3)
Etendre sur la colonne...

Cordialement.
b
bl27
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 16 mars 2017
Version d'Excel : 2013

Message par bl27 » 27 novembre 2017, 18:33

C'est exactement ce que je cherchais. Merci beaucoup!!! :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message