Fonction RTD et RECHECHEV Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MKHS
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 2 novembre 2017
Version d'Excel : 2007

Message par MKHS » 2 novembre 2017, 16:25

Bonjour à tous,
​Je vous écris car j'ai besoin de votre aide concernant un fichier Excel dans le domaine de la finance.​

J'importe des données depuis un logiciel de finance sur mon fichier excel.

Pour importer un prix​,​ par exemple d'un sous-jacent, je dois utiliser la formule suivante :
=RTD(''xtapi.rtd'';;C8;B10) ceci m'affiche la dernière cotation en temps réel ex 2930 ​d'un indice. (Le résultat s'affiche en cellule 10).

J'ai un tableau sur deux colonnes et je souhaite effectuer la requête suivante :

Par rapport ​à​ ma dernière cotation affichée, je souhaite la rechercher dans mon tableau​ à​ ​​deux colonnes, trouver le même prix pour enfin ​en​ afficher le résultat de​ la case ​à côté.

= RECHERCHEV(C10;O:P;2;FAUX)
Le résultat est #N/A..

Lorsque j'affiche les étapes de calcul j'observe bien que lorsque la formule lis le paramètre C10 qui fait référence a la formule RTD(.....)

Je voulais savoir tout d'abord si il était possible d’écrire une formule qui affiche le résultat d'une autre formule (rtd).

Merci pour votre aide.
Screen1.png
Avatar du membre
VH_AE
Membre dévoué
Membre dévoué
Messages : 593
Appréciation reçue : 1
Inscrit le : 28 février 2017
Version d'Excel : 2010

Message par VH_AE » 2 novembre 2017, 16:31

Bonjour,

Peut tu mettre un fichier pour exemple ? Que je travail dessus. La recherche V est capricieuse des fois. ^^.

Cdlt,
J'apprendrai à pêcher à celui qui a envie d'apprendre, et qui apporte sa canne à pêche.
M
MKHS
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 2 novembre 2017
Version d'Excel : 2007

Message par MKHS » 2 novembre 2017, 16:49

Merci pour votre réactivité !
Voici le fichier en pièce jointe.

Cependant, il me semble que sans le logiciel aucune donnée ne sera afficher pour les formules RTD.
Forum Excel.xlsx
(21.27 Kio) Téléchargé 7 fois
Avatar du membre
VH_AE
Membre dévoué
Membre dévoué
Messages : 593
Appréciation reçue : 1
Inscrit le : 28 février 2017
Version d'Excel : 2010

Message par VH_AE » 3 novembre 2017, 09:05

Re,

Oui effectivement le fichier ne me sert à rien mais je voulais vérifier quelque chose :roll:

Bon.. sa doit être une histoire de format. Ta rechercheV ne doit pas reconnaître la correspondance entre les deux données car elles ont pas le même format.

Essaie sur ta formule RTD de mettre CNUM ou TEXTE.
=CNUM(RTD(''xtapi.rtd'';;C8;B10))
=TEXTE(RTD(''xtapi.rtd'';;C8;B10)) 
Je ne suis pas sur de moi !

Cdlt,
J'apprendrai à pêcher à celui qui a envie d'apprendre, et qui apporte sa canne à pêche.
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 3 novembre 2017, 09:32

Bonjour,

Salut VH_AE ... :wink:

Tu utilises Real Time Data pour extraire des données actualisées on-line depuis un serveur ...

Donc, deux questions se posent :

1. As-tu une macro qui construit un historique sur la base de tous tes ' Last ' ...

2. Très probablement, ton serveur doit offrir la possibilité de faire des recherches historiques ...
Donc, il suffirait de rechercher comment y accéder directement ... sans construire ton propre historique ...
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
M
MKHS
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 2 novembre 2017
Version d'Excel : 2007

Message par MKHS » 3 novembre 2017, 11:04

Bonjour,

J'ai appliqué CNUM sur ma formule RTD, ça fonctionne, c'est parfait !

Merci à vous.
Avatar du membre
VH_AE
Membre dévoué
Membre dévoué
Messages : 593
Appréciation reçue : 1
Inscrit le : 28 février 2017
Version d'Excel : 2010

Message par VH_AE » 3 novembre 2017, 11:17

MKHS a écrit :Bonjour,

J'ai appliqué CNUM sur ma formule RTD, ça fonctionne, c'est parfait !

Merci à vous.
Bonjour,

Hello @James, :¬OL: Mission accomplie.

Cool que sa fonctionne, Bonne journée !
J'apprendrai à pêcher à celui qui a envie d'apprendre, et qui apporte sa canne à pêche.
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 3 novembre 2017, 13:46

VH_AE a écrit : Bonjour,

Hello @James, :¬OL: Mission accomplie.

Cool que sa fonctionne, Bonne journée !

Bien vu ...

Chat m'étonne pas ... :wink:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message