SOUSTRAIRE UN NOMBRE PAR RAPPORT A UNE REFERENCE Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Kassou
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 20 octobre 2014
Version d'Excel : 2016 FR

Message par Kassou » 2 novembre 2017, 15:46

Bonjour,
J'ai un fichier excel avec 2 onglets. le 1er onglet est une liste de référence article et le 2è onglet est mon stock.
Ce que je voudrais faire (pour éviter de compter à chaque fois toutes mes références articles) est que quant dans le 1er onglet je saisie une référence, il me la soustrait dans mon onglet stock
ex : 1er onglet je tape la référence 32240 et dans le 2è onglet (j'en ai 10 de cette référence), il doit me mettre 9
Sauriez vous m'aider à faire ça ?
Merci de votre aide
FICHIER EXEMPLE.xlsx
(649.82 Kio) Téléchargé 12 fois
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'717
Appréciations reçues : 333
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 2 novembre 2017, 17:13

Bonjour,

pour la quantité de chaque réf.
=NB.SI(RECAP!$I:$P;'STOCK 9703'!$A2)
à recopier vers le bas
Vive ces nouvelles saisons qui nous colorent.
isabelle
Avatar du membre
Kassou
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 20 octobre 2014
Version d'Excel : 2016 FR

Message par Kassou » 2 novembre 2017, 18:44

Ta formule ne fait que rechercher une référence. Ce que je voudrais c'est que la formule fasse une recherche et ensuite la soustrait.
Par ex : J'ai un stock de 4 articles référence 01862. Si j'en vends 1, il doit m'en rester 3
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'717
Appréciations reçues : 333
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 2 novembre 2017, 19:10

en cellule D2 de l'onglet "STOCK 9703"
=C2-NB.SI(RECAP!$I:$P;A2)
à recopier vers le bas
Vive ces nouvelles saisons qui nous colorent.
isabelle
Avatar du membre
Kassou
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 20 octobre 2014
Version d'Excel : 2016 FR

Message par Kassou » 2 novembre 2017, 20:13

C'est exactement ça ! un très grand merci pour ton aide.
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'717
Appréciations reçues : 333
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 2 novembre 2017, 20:31

Merci pour ce retour, au plaisir!
si le problème est résolu, s.v.p. pour clôturer le fil, cliquer sur le bouton V vert du post à coté du bouton EDITER, merci!
Vive ces nouvelles saisons qui nous colorent.
isabelle
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message