Totaliser selon l'année de référence Le sujet est résolu

Forum pour toutes vos questions à propos d'Excel (avec ou sans macros) ...
Avatar du membre
Zazalisa
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 16 septembre 2017
Version d'Excel : 2016 FR

Message par Zazalisa » 16 mai 2018, 13:31

Bonjour tout le monde,

Je n'arrive pas à trouver la bonne formule pour un tableau (ex en pièce jointe). J'aimerais faire un total des sommes correspondant à 2017 et un total des sommes pour 2018. J'ai essayé plusieurs formules avec SI ou SOMME.SI, j'ai également tenté avec Date Valeur mais ça ne fonctionne pas :oops:

Par avance merci
:ppg:
"Plus on a médité, plus on est en état d’affirmer qu’on ne sait rien."
Voltaire -
Avatar du membre
Zazalisa
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 16 septembre 2017
Version d'Excel : 2016 FR

Message par Zazalisa » 16 mai 2018, 13:32

Oups ... le fichier !
Fichiers joints
Si 2017 additionner, si 2018 autre addition.xlsx
(9.51 Kio) Téléchargé 7 fois
"Plus on a médité, plus on est en état d’affirmer qu’on ne sait rien."
Voltaire -
Avatar du membre
bigdaddy154
Membre impliqué
Membre impliqué
Messages : 1044
Appréciations reçues : 25
Inscrit le : 5 mars 2014
Version d'Excel : 2010

Message par bigdaddy154 » 16 mai 2018, 13:47

Bonjour Zazalisa,

pour 2017 :

Code : Tout sélectionner

=SOMMEPROD((ANNEE($A$2:$A$9)=2017)*($D$2:$D$9))
Bonne journée
gullaud
Membre fidèle
Membre fidèle
Messages : 231
Appréciations reçues : 5
Inscrit le : 13 décembre 2016
Version d'Excel : 2013

Message par gullaud » 16 mai 2018, 13:51

j'ai ajouter une colonne année
Fichiers joints
Si 2017 additionner, si 2018 autre addition (2).xlsx
(10.55 Kio) Téléchargé 2 fois
Avatar du membre
Zazalisa
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 16 septembre 2017
Version d'Excel : 2016 FR

Message par Zazalisa » 16 mai 2018, 13:57

Bonjour Bigdaddy et Gullaud

Merci à tous les deux pour vos réponses rapides et super efficaces !
Bonne journée
:ppg:
"Plus on a médité, plus on est en état d’affirmer qu’on ne sait rien."
Voltaire -
gullaud
Membre fidèle
Membre fidèle
Messages : 231
Appréciations reçues : 5
Inscrit le : 13 décembre 2016
Version d'Excel : 2013

Message par gullaud » 16 mai 2018, 15:08

je te conseille d'utiliser la notion de tableau (insertion/tableau)
quand tu ajoute une ligne elle est prise en compte dans le calcul
Fichiers joints
Si 2017 additionner, si 2018 autre addition (3).xlsx
(14.01 Kio) Téléchargé 1 fois
Avatar du membre
Zazalisa
Membre habitué
Membre habitué
Messages : 72
Inscrit le : 16 septembre 2017
Version d'Excel : 2016 FR

Message par Zazalisa » 16 mai 2018, 17:42

Oui, c'est fait !

Merci merci
:ppg:
"Plus on a médité, plus on est en état d’affirmer qu’on ne sait rien."
Voltaire -
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message