date en format numerique

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
Répondre
a
adesmarais365
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 juillet 2017
Version d'Excel : 2013

Message par adesmarais365 » 12 juillet 2017, 22:05

Bonjour,

j<ai fait une recherchev sur un fichier et jai obtenu une valeur date mais lorsque je la compare a un autre fichier,
jai deux valeurs differentes. Une de 42868 et une de 42868.683. je veux verifier que les deux ont la meme date.
pourtant avec la recherchev j<ai la meme date mais pas la meme valeur texte. est-ce quil y a moyen darriver a la meme valeur
soit par arrondissement de valeur premier ou autre. Aidez-moi svp. merci
n
njhub
Membre impliqué
Membre impliqué
Messages : 1'517
Appréciations reçues : 90
Inscrit le : 5 juin 2017
Version de Calc : LO 6352 FR-YT

Message par njhub » 13 juillet 2017, 03:53

Bonjour adesmarais365

la partie décimale contient l'heure, vous pouvez donc la supprimer si vous n'avez besoin que de la date.

42868
=TEXTE(42868;"jj mmmm aaaa hh:mm:ss")
renvoie 13 mai 2017 00:00:00
42868,683
=TEXTE(42868,683;"jj mmmm aaaa hh:mm:ss")
renvoie 13 mai 2017 16:23:31

avec la virgule comme séparateur décimal on peut utiliser la valeur directement dans la formule,
avec le point comme séparateur décimal mettre la valeur entre guillemets.

42868.683
=TEXTE(GAUCHE("42868.683";5);"jj mmmm aaaa hh:mm:ss")
renvoie 13 mai 2017 00:00:00
=TEXTE(GAUCHE(C4;5);"jj/mm/aa")
renvoie 13/05/17
Avatar du membre
mdo100
Membre dévoué
Membre dévoué
Messages : 937
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 13 juillet 2017, 10:02

Bonjour adesmarais365, njhub,

Exemple si en "A1" = 42868,683
Alors on récupère la date en "B1"
=ENT(A1)
mettre au format Date, la Date est donc au format numérique.

On peut aussi imaginer récupérer l'heure dans une autre cellule.
En "C1"
=MOD(A1;1)
mettre au format Heure, l'Heure est donc au format numérique.

Cordialement.
a
adesmarais365
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 juillet 2017
Version d'Excel : 2013

Message par adesmarais365 » 13 juillet 2017, 14:26

Merci Ca fonctionne.

Andre
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message