Détecter les mots écrite plus le nombre de fois répéter (chaque mois)

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
M
Musto
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 18 avril 2019
Version d'Excel : Excel 201

Message par Musto » 18 avril 2019, 12:44

Bonjour,
J'ai un problème : j'ai une colonne A(date) et B,C,D des colonnes qui contient des valeurs de type texte je veux savoir les valeurs(texte)détecter pour chaque mois plus compter le nombre de fois répéter pour chaque mois aussi. Merci D'avance
Valeur fin mois (Enregistré automatiquement).xlsx
(11.14 Kio) Téléchargé 1 fois
m
m3ellem1
Membre dévoué
Membre dévoué
Messages : 661
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 19 avril 2019, 09:42

Bonjour Musto :bv:

à tester



Il y a le cas de TR, dans la liste on voit duex TR. La cause c'est un espace.

Pour l'éviter il faut faire deux changement:

on Trim les valeurs:
Sub SansDoublons()
Dim rng As Range
Dim ListeInit As Range, Resultat As Range
Dim DerLigne As Integer
Set dt = CreateObject("Scripting.Dictionary")

DerLigne = ActiveSheet.Cells(Rows.Count, 1).End(xlUp).Row
Set ListeInit = Range("B2:D" & DerLigne)
Set Resultat = Range("F2")

For Each rng In ListeInit
    If rng.Value <> "" Then
        dt(Trim(rng.Value)) = ""
    End If
Next
Resultat.Range("A1").Resize(dt.Count) = Application.WorksheetFunction.Transpose(dt.Keys)
Columns("F:F").Sort key1:=Range("F2"), order1:=xlAscending, Header:=xlYes
End Sub
et on adapte la formule en ajoutant un SUPPRESPACE:
=SIERREUR(SI(F2="";"";SOMMEPROD((ANNEE($A$2:$A$69)=ANNEE($G$1))*(MOIS($A$2:$A$69)=MOIS($G$1))*(SUPPRESPACE($B$2:$D$69)=F2)));"")
Un nouveau fichier avec les deux versions:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message