Aide recopie date

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
P
PaulTT
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 20 mars 2019
Version d'Excel : 2019FR
Version de Calc : 6.1.4 FR

Message par PaulTT » 20 mars 2019, 15:28

Bonjour à tous, j'ai besoin de votre aide : Sur mon document excel j'ai plusieurs feuilles où j'ai sur ces feuilles les mêmes dates en colonnes (dates de jours pour un mois entier cad 01/02/19 02/02/19... jusqu'au 28/02/2019). Ce que je souhaite est quand je modifie les dates sur ma première feuille ça change également celles sur mes autres feuilles. Pour ça, j'ai mis dans mes feuilles autre que la première : =(la cellule où se trouve la date sur ma première feuille). Si tous les mois avaient la même longueur je n'aurais aucun problème, mais par exemple quand je vais passer sur les dates de mars sur ma 1ère feuille sur les autres feuilles ça va s'arrêter au 28/03/19 car si la formule "=(la cellule où se trouve la date sur ma première feuille)" s'étend jusqu'au 31 dès que le mois va pas jusqu'au 31 sur ma première colonne, sur les autres feuilles une fois la fin du mois ça reprend avec le 01/01/1900 il me semble.

Le fait est que j'aimerais que ça recopie juste les dates de la première feuille, que quand le mois devient plus court, les jours restants n'affiche rien et pas que ça recommence au 01/01/1900.

Je sais que mon explication n'est pas très clair, si vous avez un doute redemandez moi.
Merci de votre aide.
Cordialement, Paul
m
m3ellem1
Membre dévoué
Membre dévoué
Messages : 661
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 21 mars 2019, 08:36

Slt Paul,

Si la cellule "trouvée" est une cellule vide, cela est interprété comme 0 / sortie.

==> ou bien t'utilises la fonction SI (): = SI (ta formule = 0; ""; ta formule)
==> ou bien dans les options: tu masques les zéros (voir foto).
(il y a d'autres solutions)

Dans ton cas l'une de ces solutions vont te regler ton soucis (en fait je l'espère) :)

Solution 1:
=SI(Feuil1!A1="";"";Feuil1!A1)
ou Solution 2:
les_zeros.jpg
sinon mets nous un fichier s'il te plaît.
Bonne journée
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 1'199
Appréciations reçues : 77
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 21 mars 2019, 09:49

Bonjour,
Un fichier exemple serait plus facile à comprendre.

(Puisque tu parles de fichier excel tu le travail avec calc ? )
n
njhub
Membre dévoué
Membre dévoué
Messages : 850
Appréciations reçues : 33
Inscrit le : 5 juin 2017
Version d'Excel : LO CALC 6.1.4.2 261218 FR-YT

Message par njhub » 21 mars 2019, 19:18

Bonjour PaulTT,

Il faut résoudre le problème dans la feuille initiale.
Jusqu'au 28 du mois pas de problème particulier.
A partir du 29, dans l'hypothèse dans laquelle votre première date se situe en ligne 1,
donc en ligne 29 :
=SI(MOIS(A$28+LIGNE()-28)=MOIS(A$28);A$28+LIGNE()-28;"")
Voyez si le fichier joint peut vous aider
PaulTT.ods
(14.52 Kio) Téléchargé 2 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Format de date et recopie
    par Filou78 » 31 août 2015, 09:23 » dans Excel - VBA
    6 Réponses
    92 Vues
    Dernier message par Filou78
    2 septembre 2015, 14:34
  • Recopie d'une cellule en fonction de la date et l'heure
    par seb92110 » 21 mars 2018, 15:17 » dans Excel - VBA
    4 Réponses
    76 Vues
    Dernier message par seb92110
    6 avril 2018, 14:33
  • Recopie
    par MaxWell » 30 octobre 2015, 07:56 » dans Excel - VBA
    5 Réponses
    171 Vues
    Dernier message par jmd
    30 octobre 2015, 11:32
  • Recopie
    par jpvill » 22 mai 2019, 10:14 » dans Excel - VBA
    4 Réponses
    45 Vues
    Dernier message par jpvill
    22 mai 2019, 14:32
  • recopie de formules
    par Lougo » 14 octobre 2018, 15:02 » dans Excel - VBA
    4 Réponses
    61 Vues
    Dernier message par dhany
    14 octobre 2018, 15:22
  • RECOPIE INCRÉMENTÉE
    par GRINCH » 30 juillet 2015, 11:42 » dans Excel - VBA
    3 Réponses
    734 Vues
    Dernier message par GRINCH
    2 août 2015, 12:10