Demande de formulr

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
V
Vincent 59153
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 28 janvier 2019
Version d'Excel : 2013
Version de Calc : 15.0.5093.1000

Message par Vincent 59153 » 28 janvier 2019, 14:01

Bonjour
J'aurais besoin de votre aide svp

Je cherche le moyen de calculer le nombre de fois où la série de cellules J suivi de la cellule M se répète dans une ligne contenant
JMANJMMANJMJAJMNRJMAJR

Merci d avance pour vos réponses
Cordialement
Avatar du membre
Pedro22
Membre impliqué
Membre impliqué
Messages : 2'281
Appréciations reçues : 233
Inscrit le : 26 janvier 2017
Version d'Excel : 2010

Message par Pedro22 » 28 janvier 2019, 15:11

Bonjour Vincent,

Peux-tu illustrer ta demande avec un fichier, plutôt qu'une série de lettres qui n'est (en ce qui me concerne) pas très parlante.
Le problème n'est pas de ne pas savoir, le problème est de ne pas chercher...
Ton problème est résolu ? N'oublie pas de l'indiquer :
n
njhub
Membre dévoué
Membre dévoué
Messages : 850
Appréciations reçues : 33
Inscrit le : 5 juin 2017
Version d'Excel : LO CALC 6.1.4.2 261218 FR-YT

Message par njhub » 28 janvier 2019, 17:13

Bonjour Vincent59153,

Essayez avec un formule du type si vos données sont en ligne 1 de la colonne A à V:
=SOMME(NBCAR(CONCAT(A1:V1));-NBCAR(SUBSTITUE(CONCAT(A1:V1);"JM";"")))/2
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'698
Appréciations reçues : 646
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 28 janvier 2019, 17:52

Bonjour Vincent, le forum,

:bv:

sur une ligne Excel de A à XFD, il y a toujours une cellule J et une cellule M ; et la cellule M suit la cellule J

aussi, j'ai compris ainsi la phrase de ton énoncé :

« Je cherche le moyen de calculer le nombre de fois où la lettre J suivie de la lettre M se répète dans le texte
JMANJMMANJMJAJMNRJMAJR
»


si tu as "JMANJMMANJMJAJMNRJMAJR" en A1,

je propose cette formule :

=(NBCAR(A1)-NBCAR(SUBSTITUE(A1;"JM";"")))/2

retour : 5

@njhub : je crois que la « ligne » dont parle Vincent est simplement le long texte "JMANJMMANJMJAJMNRJMAJR" qui est contenu dans une seule cellule ; si je me suis trompé, c'est ta formule qui convient mieux.  :wink:

dhany
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 janvier 2019, 20:46

Bonsoir le forum,

Si une lettre par cellule :
=SOMMEPROD((A1:V1="J")*(B1:W1="M"))
SOMMEPROD.png
SOMMEPROD.png (7.45 Kio) Vu 389 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 janvier 2019, 23:03

Re,

Avec la même hypothèse, les couples peuvent être repérés avec une mise en forme conditionnelle :
MFC.gif
MFC.gif (16.65 Kio) Vu 377 fois
V
Vincent 59153
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 28 janvier 2019
Version d'Excel : 2013
Version de Calc : 15.0.5093.1000

Message par Vincent 59153 » 30 janvier 2019, 11:42

Bonjour
Merci a vous tous pour vos réponses cela correspond tout à fait à ma recherche si ce n' est pas abusé j aurais encore une demande
Comment calculer toujours dans une série de cellule comme par exemple celle ci
jrpmjrppamjmjrrrnjrrppmjrrppam

Le nombre de "jm" en sachant que maintenant il y peut y avoir ou non d autres cellules entre les "jm"
Et surtout que si le "j" rencontre un "a" ou un "n" avant le "m" alors il comptabilise un "ja" ou un "jn" au lieu de "jm"
Merci d'avance
Cordialement
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 janvier 2019, 13:49

Re,
Lettres.gif
Lettres.gif (22.6 Kio) Vu 322 fois
V
Vincent 59153
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 28 janvier 2019
Version d'Excel : 2013
Version de Calc : 15.0.5093.1000

Message par Vincent 59153 » 30 janvier 2019, 15:05

EXEMPLE.xlsx
(8.15 Kio) Téléchargé 7 fois

Je vous ai joint une photo du fichier de base
Ce que je souhaite c est compter le nombre de jM dans la série même si il y a des cellules entre le j et le M par contre si le j rencontre un A ou un N dans la série avant un M alors il comptabilise un jA ou un jN
Au final je veux connaître le nombre de jM de jA et de jN

Dans votre réponse la série de caractères ne correspond pas à mon fichier
J espère avoir été plus clair
Merci d'avance
V
Vincent 59153
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 28 janvier 2019
Version d'Excel : 2013
Version de Calc : 15.0.5093.1000

Message par Vincent 59153 » 30 janvier 2019, 15:09

En fait les P et R correspondent a des repos et moi je veux connaître le nombre de fois dans le mois ou j' ai effectué des JM(jour matin):des JA( jour après midi) et des JN(jour nuit) même si le jour n est pas accolle au M,A,ou N
Voilà
Encore merci
Répondre Sujet précédentSujet suivant