Formule calcule du % d'honoraire. Le sujet est résolu

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
b
blade
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 6 décembre 2018
Version d'Excel : 2016

Message par blade » 6 décembre 2018, 01:02

Bonjour,

J'ai besoin d'aide pour créer une formule de calcule d'honoraire en immobilier.

J'ai besoin de rentrer cette équation :

A = prix de ventre FAI
B = honoraire
x = pourcentage

Formule :
Ax/100=B

Comment faire ce calcul sur mon excel. A savoir que A et B sont des variable à entrer et x le résultat en %.

Merci pour votre aide.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'689
Appréciations reçues : 647
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 6 décembre 2018, 03:07

Bonjour blade,

:bv:

je te propose ce fichier Excel :
Exo blade.xlsx
(9.46 Kio) Téléchargé 35 fois
si besoin, tu peux demander une adaptation.
merci de me dire si ça te convient.

dhany
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 6 décembre 2018, 12:41

Bonjour le forum,
=B2/A2
Format : pourcentage
%.png
%.png (3.97 Kio) Vu 2304 fois
b
blade
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 6 décembre 2018
Version d'Excel : 2016

Message par blade » 6 décembre 2018, 12:43

Bonjour Dhany,

Génial !!! super efficace. Au top.

Du coup j'essaie de comprendre la formule.

A quoi sert la commande "=Si(ou(B1=0;b2=0) ?

les ;""; servent à imbriquer une seconde formule ?

Pour la solution 2 j'ai bien compris que la colonne B9 est en pourcentage... ce qui revient à faire avec la B3 le *100

J'ai un tableau complet avec des forfaits en fonction du prix de vente. Je vais essayé de faire quelque chose de propre qui en fonction du montant de vente je puisse avoir un récupération de la valeur du "forfait" afin de l'intégrer au calcul.
Je ne sais pas quelle commande utiliser du coup, car il faudrait gérer un genre de base de données, non ?

je te joins mon tableau tu pourras peut être mieux comprendre.

En tout cas, merci, super boulot ! :wink:

Christophe.
honoraires 2018.xlsx
honoraires tableau
(33.88 Kio) Téléchargé 21 fois
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'689
Appréciations reçues : 647
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 7 décembre 2018, 14:22

Bonjour Christophe,
tu a écrit :À quoi sert la formule =SI(OU(B1=0;B2=0).. ? les ;""; servent à imbriquer une seconde formule ?
je remets ici la formule complète : =SI(OU(B1=0;B2=0);"";B2/B1*100)

syntaxe de la fonction SI() : =SI(Condition;RetourSiConditionEstVraie;RetourSiConditionEstFausse)
les 2 signes « ; » (point-virgule) servent à séparer les 3 arguments de la fonction SI.

Condition : avec une seule condition si B1=0, ça aurait été : =SI(B1=0;..
avec 2 conditions si B1=0 et B2=0, ça aurait été : =SI(ET(B1=0;B2=0);..
avec 2 conditions si B1=0 ou B2=0, c'est : =SI(OU(B1=0;B2=0);..

attention : pour B1 ou B2 : ça vaut 0 si tu saisis un 0 ; mais aussi si la cellule est vide !
donc la condition est Vraie dans ces 2 cas :

si (B1 est vide ou contient 0) OU (B2 est vide ou contient 0)

Condition Vraie ➯ retour du 2ème argument  "" qui est une chaîne de caractères vide ; donc la cellule B3 est vide

note importante : le calcul à faire contient une division par B1, or une division par 0 est mathématiquement impossible et retourne le message d'erreur #DIV/0! ; le test B1=0 permet d'éviter ce message d'erreur ➯ retour : vide au lieu de #DIV/0!

Condition Fausse ➯ retour du 3ème argument  B2/B1*100 ; donc la cellule B3 contient ton pourcentage

dhany
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'689
Appréciations reçues : 647
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 7 décembre 2018, 14:30

Re Christophe,

je te retourne ton fichier modifié :
honoraires 2018.xlsm
(42.55 Kio) Téléchargé 19 fois
saisis en D24 ton Montant de venteHonoraires affichés en D25

Alt F11 pour voir le code VBA, puis revenir sur Excel

si besoin, tu peux demander une adaptation.
merci de me dire si ça te convient.

dhany  Image
b
blade
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 6 décembre 2018
Version d'Excel : 2016

Message par blade » 7 décembre 2018, 18:56

Bonjour Dhany,

J'ai super ce que tu as fait.

J'ai trop de mal avec la règle de trois et a chaque fois je me prendre la tête pour calculer. Pour le moment j'ai pas eu trop à le faire, je commence mon activité immobilière à peine.

J'essaie de comprendre ce que tu as fait. Je savais même pas qu'on pouvait intégrer du VB.

En tout cas Merci.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'689
Appréciations reçues : 647
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 7 décembre 2018, 19:14

merci pour ton retour !  :D  pour passer le sujet en résolu, il suffit de cliquer sur le bouton près de (regarde dans le coin haut droit du post) ; ça permet aussi de clôturer le fil de la discussion ; tu sauras que tu as réussi quand tu verras un petit rond vert avec une coche, comme ceci :
Sujet résolu.jpg
Sujet résolu.jpg (7.99 Kio) Vu 2263 fois
(toi seul peut le faire, car c'est toi qui a créé ce sujet)

bonne continuation pour la suite de ton activité immobilière !  :trfl:  et bonnes fêtes de Noël !  :noel:

dhany
b
blade
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 6 décembre 2018
Version d'Excel : 2016

Message par blade » 8 décembre 2018, 23:22

encire merci...

Bonnes fêtes également.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message