Fonction SOMMEPROD Le sujet est résolu

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
N
Nico13000
Jeune membre
Jeune membre
Messages : 18
Appréciation reçue : 1
Inscrit le : 14 novembre 2018
Version d'Excel : 2013 FR

Message par Nico13000 » 25 novembre 2018, 08:51

Bonjour,

Je souhaite utiliser la fonctionne SOMMEPROD pour additionner les valeurs d'une ligne si le texte d'une autre ligne contient un certain terme.

Par exemple si dans la ligne 1 du "classeur1.xls", il y a des cellules qui contiennent le texte "L1" alors il faut additionner les valeurs contenues dans la ligne 2.

Voici ma formule qui est dans le classeur2.xls:
=SOMMEPROD(('C:\Users\nico\Desktop\[Classeur 1.xlsx]Feuil1'!$A$1:$D$1="L1")*('C:\Users\nico\Desktop\[Classeur 1.xlsx]Feuil1'!$A$2:$D$2))

Le problème est que si les cellules de la ligne 1 ne contiennent pas strictement le texte "L1" il ne trouve rien.
Est-ce que quelqu'un sait comment améliorer cette formule afin que si dans la ligne 1, il y a du texte qui contient "L1" avec autre chose derrière ça fonctionne aussi ?

Je mets en pièce jointe mes deux classeurs afin que ça soit plus parlant ::D

A noter qu'il faut deux classeurs séparés : le classeur2.xls qui va chercher dans le classeur1.xls.

Merci encore pour votre aide précieuse !! :P :P ;;)
Classeur 2.xlsx
(8.69 Kio) Téléchargé 23 fois
Classeur 1.xlsx
(7.8 Kio) Téléchargé 26 fois
N
Nico13000
Jeune membre
Jeune membre
Messages : 18
Appréciation reçue : 1
Inscrit le : 14 novembre 2018
Version d'Excel : 2013 FR

Message par Nico13000 » 25 novembre 2018, 10:20

PS : à noter que j'utilise la fonction SOMMEPROD car si j'utilise les fonctions du type SOMME, lorsque je ferme le classeur1.xls la formule ne marche plus et ça renvoi #VALEUR dans le classeur2.xls.
Avatar du membre
lauange
Membre fidèle
Membre fidèle
Messages : 213
Appréciation reçue : 1
Inscrit le : 2 février 2016
Version d'Excel : 2013FR

Message par lauange » 25 novembre 2018, 10:26

ajoute simplement une * dans ton expression "L1*". Cela devrait fonctionner.
Excel 2010 windows et Excel 2016 Mac OSX
N
Nico13000
Jeune membre
Jeune membre
Messages : 18
Appréciation reçue : 1
Inscrit le : 14 novembre 2018
Version d'Excel : 2013 FR

Message par Nico13000 » 25 novembre 2018, 10:31

lauange a écrit :
25 novembre 2018, 10:26
ajoute simplement une * dans ton expression "L1*". Cela devrait fonctionner.
Bonjour,

Oui j'ai essayé mais du coup il cherche strictement le texte L1* au lieu de chercher tout ce qui contient du texte L1 avec quelque chose derrière :bof: ::)
Avatar du membre
lauange
Membre fidèle
Membre fidèle
Messages : 213
Appréciation reçue : 1
Inscrit le : 2 février 2016
Version d'Excel : 2013FR

Message par lauange » 25 novembre 2018, 11:44

Bien vu, Si le résultat que tu attends est 8, alors utilise cette formule :

=SOMME.SI.ENS('[Classeur 1.xlsx]Feuil1'!$A$2:$D$2;'[Classeur 1.xlsx]Feuil1'!$A$1:$D$1;"L1-*")
Excel 2010 windows et Excel 2016 Mac OSX
N
Nico13000
Jeune membre
Jeune membre
Messages : 18
Appréciation reçue : 1
Inscrit le : 14 novembre 2018
Version d'Excel : 2013 FR

Message par Nico13000 » 25 novembre 2018, 11:59

lauange a écrit :
25 novembre 2018, 11:44
Bien vu, Si le résultat que tu attends est 8, alors utilise cette formule :

=SOMME.SI.ENS('[Classeur 1.xlsx]Feuil1'!$A$2:$D$2;'[Classeur 1.xlsx]Feuil1'!$A$1:$D$1;"L1-*")
Yes, alors j'ai déjà utilisé cette formule et qui fonctionne. Mais lorsque je ferme le fichier qui contient les données (Classeur1.xls) et que je réouvre le classeur2.xls il m'affiche #VALEUR!

En fait j'ai remarqué que les fonctions du type SOMME ne fonctionne plus quand il y a des liaisons vers d'autres fichier Excel.

C'est pour cela que j'utilise la fonction SOMMEPROD qui règle à ce problème :| :bof:
N
Nico13000
Jeune membre
Jeune membre
Messages : 18
Appréciation reçue : 1
Inscrit le : 14 novembre 2018
Version d'Excel : 2013 FR

Message par Nico13000 » 25 novembre 2018, 14:18

J'ai trouvé !!

Il fallait entrer :

=SOMMEPROD((ESTNUM(CHERCHE("L1*";'C:\Users\nico\Desktop\[Classeur 1.xlsx]Feuil1'!$A$1:$D$1)))*('C:\Users\nico\Desktop\[Classeur 1.xlsx]Feuil1'!$A$2:$D$2))

::D ::D
1 membre du forum aime ce message.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Fonction Joursem dans une Fonction SommeProd
    par Mp45 » 24 avril 2014, 16:22 » dans Excel - VBA
    3 Réponses
    606 Vues
    Dernier message par Jean-Eric
    24 avril 2014, 18:50
  • Fonction SOMMEPROD
    par Siva » 6 octobre 2014, 17:30 » dans Excel - VBA
    17 Réponses
    298 Vues
    Dernier message par Siva
    8 octobre 2014, 05:06
  • fonction sommeprod
    par Vincent71 » 5 novembre 2018, 16:30 » dans Excel - VBA
    3 Réponses
    138 Vues
    Dernier message par M12
    5 novembre 2018, 16:56
  • fonction sommeprod
    par nectarine78 » 13 novembre 2014, 11:38 » dans Excel - VBA
    3 Réponses
    99 Vues
    Dernier message par Jean-Eric
    13 novembre 2014, 14:36
  • Fonction Sommeprod ?
    par Camille91 » 22 janvier 2019, 10:17 » dans Excel - VBA
    13 Réponses
    153 Vues
    Dernier message par Camille91
    22 janvier 2019, 11:57
  • Fonction SOMMEPROD
    par sophang » 14 décembre 2015, 09:53 » dans Excel - VBA
    2 Réponses
    114 Vues
    Dernier message par sophang
    14 décembre 2015, 13:35