formule sierreur index equiv

Forum pour toutes vos questions à propos de LibreOffice/OpenOffice Calc ...
TOUATI
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 18 juin 2018
Version d'Excel : excel2010

Message par TOUATI » 31 juillet 2018, 10:37

Bonjour
Pourriez vous m’interpréter la formule appliquée svp!!
Copie de HABIBA.xlsx
(13.32 Kio) Téléchargé 12 fois
Merci de bien vouloir m’aider
Avatar du membre
xorsankukai
Membre dévoué
Membre dévoué
Messages : 603
Appréciations reçues : 29
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 8 août 2018, 08:39

Bonjour TOUATI,

Je tente l'explication:

Code : Tout sélectionner

=SIERREUR(INDEX('Feuil 1'!D:D;EQUIV($C12&$D12;'Feuil 1'!$A:$A&'Feuil 1'!$B:$B;0));"")
=SIERREUR(formule);" ") : si aucune correspondance (donc erreur), on laisse la cellule vide

En G12:

Code : Tout sélectionner

INDEX('Feuil 1'!D:D
on recherche la correspondance dans la feuille 1 en colonne D
:

Code : Tout sélectionner

$C12&$D12
les critères(feuille 2) sont C12 et D12
:

Code : Tout sélectionner

EQUIV($C12&$D12;'Feuil 1'!$A:$A&'Feuil 1'!$B:$B;0)
on recherche donc ces critères respectivement en colonne A et colonne B de la feuille 1
La formule est entre crochets, il s'agit donc d'une formule matricielle à valider par Maj+Ctrl+entrée

Je ne suis pas très doué pour les explications, mais j'éspère t'avoir un peu éclairé, ;;)

Pour te familiariser avec les fonctions INDEX et EQUIV regarde ici:
https://www.excel-pratique.com/fr/fonct ... _equiv.php
http://boisgontierjacques.free.fr/pages ... nindex.htm

Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message