Signe du zodiaque

Pour écrire et partager des tutoriels et des astuces avec les autres membres (Excel ou VBA uniquement)
d
dre
Membre impliqué
Membre impliqué
Messages : 1'999
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 24 février 2008, 18:21

Formule qui renvoie le signe du zodiaque correspondant à une date en A1.

Le choix entre :
=SI(A1="";"";RECHERCHEV(DATE(;MOIS(A1);JOUR(A1));{0\"Capricorne";21\"Verseau";51\"Poisson";81\"Bélier";112\"Taureau";142\"Gémeaux";174\"Cancer";206\"Lion";237\"Vierge";268\"Balance";298\"Scorpion";328\"Sagittaire";356\"Capricorne"};2)) 
=SI(A1="";"";INDEX({"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"};EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356};1))) 
=SI(A1="";"";CHOISIR(EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356});"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"))
dré
m
mitch07
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 11 août 2016
Version d'Excel : 2016

Message par mitch07 » 11 août 2016, 12:03

Bonjour merci pour cette formule bien pratique.Après utilisation et vérification , je pense qu'il y a des petites erreurs dans la formule

- ajouter Capricorne à la fin car ce signe chevauche la fin d'année et le début d'année; dans la version initiale les dates de naissance entre le 357 ème et le 365 ème jour ne donnaient pas de résultat.
-les numéros d'index n'étaient pas tout à fait justes (à un jour près)

Je mets la version revue qui devrait renvoyer les bons résultats.
=SI(D5="";"";INDEX({"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire";"Capricorne";""};EQUIV(DATE(;MOIS(D5);JOUR(D5));{0;20;51;81;111;142;173;205;237;267;297;327;357};1)))
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message