Signe du zodiaque

Forum pour partager vos connaissances et vos astuces Excel / VBA ...
dre
Membre impliqué
Membre impliqué
Messages : 1999
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 24 février 2008, 18:21

Formule qui renvoie le signe du zodiaque correspondant à une date en A1.

Le choix entre :

Code : Tout sélectionner

=SI(A1="";"";RECHERCHEV(DATE(;MOIS(A1);JOUR(A1));{0\"Capricorne";21\"Verseau";51\"Poisson";81\"Bélier";112\"Taureau";142\"Gémeaux";174\"Cancer";206\"Lion";237\"Vierge";268\"Balance";298\"Scorpion";328\"Sagittaire";356\"Capricorne"};2)) 

Code : Tout sélectionner

=SI(A1="";"";INDEX({"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"};EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356};1))) 

Code : Tout sélectionner

=SI(A1="";"";CHOISIR(EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356});"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"))
dré
mitch07
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 11 août 2016
Version d'Excel : 2016

Message par mitch07 » 11 août 2016, 12:03

Bonjour merci pour cette formule bien pratique.Après utilisation et vérification , je pense qu'il y a des petites erreurs dans la formule

- ajouter Capricorne à la fin car ce signe chevauche la fin d'année et le début d'année; dans la version initiale les dates de naissance entre le 357 ème et le 365 ème jour ne donnaient pas de résultat.
-les numéros d'index n'étaient pas tout à fait justes (à un jour près)

Je mets la version revue qui devrait renvoyer les bons résultats.

Code : Tout sélectionner

=SI(D5="";"";INDEX({"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire";"Capricorne";""};EQUIV(DATE(;MOIS(D5);JOUR(D5));{0;20;51;81;111;142;173;205;237;267;297;327;357};1)))
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Utilisation du signe $
    par cathydeuche » 19 février 2014, 08:21 » dans Excel - VBA
    3 Réponses
    259 Vues
    Dernier message par FINDRH
    19 février 2014, 10:02
  • appliquer le signe $
    par mistral » 30 juin 2015, 16:55 » dans Excel - VBA
    5 Réponses
    199 Vues
    Dernier message par eriiic
    30 juin 2015, 22:42
  • Retirer l'affichage du signe -
    par Malynou » 26 novembre 2013, 15:56 » dans Excel - VBA
    7 Réponses
    342 Vues
    Dernier message par Malynou
    26 novembre 2013, 17:52
  • Formule avec signe <
    par 75cricri » 7 octobre 2016, 09:46 » dans Excel - VBA
    7 Réponses
    153 Vues
    Dernier message par 75cricri
    7 octobre 2016, 16:20
  • Matérialiser un changement de signe
    par sycomore » 30 novembre 2017, 16:37 » dans Excel - VBA
    14 Réponses
    226 Vues
    Dernier message par sycomore
    1 décembre 2017, 17:04
  • changé le signe d'une cellule
    par barbosa » 14 mars 2014, 10:22 » dans Excel - VBA
    8 Réponses
    591 Vues
    Dernier message par barbosa
    14 mars 2014, 15:09