Additionner des denominateur et numerateur « textes »

Forum pour partager vos connaissances et vos astuces Excel / VBA ...
JimFisher
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 16 mai 2018
Version d'Excel : 2010

Message par JimFisher » 16 mai 2018, 08:13

Bonjour,

J’ai besoin de votre aide.
Je vous explique mon problème (en espérant qu’un génie trouve la solution).

J’ai plusieurs tableaux avec des fractions sous format textes. Je précise que ce n’est pas des fractions pour ma mes collègues et moi. Ce n’est qu’une forme d’ecriture.

De ce fait, j’ai une colonne qui regroupe plusieurs données du type
1/2
2/3
1/2
2/2
Je cherche la formule qui me permet d’additionner les differents numérateurs et les différents dénominateurs indépendant.

Ainsi je cherche à la fin obtenir pour :

1/2
2/3
1/2
2/2
=
6/9

Ce n’est qu’un exemple. Je cherche réellement a trouver la somme de tout ces valeurs sous format texte.

Puisque j’ai une trentaine de tableau à compter de cette manière et les compters à la main est une énorme source d’erreur et une perte de temps colossal....et accessoirement une perte de papiers...

En espérant avoir une aide. Je vous remercie d’avance.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 4988
Appréciations reçues : 88
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 16 mai 2018, 08:30

Bonjour le forum,

=SOMMEPROD(CNUM(GAUCHE(A2:A5;1)*1))&"/"&SOMMEPROD(CNUM(DROITE(A2:A5;1)*1))

Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 4988
Appréciations reçues : 88
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 16 mai 2018, 08:49

Re,

Si le numérateur ou le dénominateur contient un nombre à la place d'un chiffre :

=SOMMEPROD(CNUM(GAUCHE(A2:A5;TROUVE("/";A2:A5)-1)))&"/"&SOMMEPROD(CNUM(DROITE(A2:A5;NBCAR(A2:A5)-TROUVE("/";A2:A5))))
JimFisher
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 16 mai 2018
Version d'Excel : 2010

Message par JimFisher » 16 mai 2018, 09:09

Merci ! Beaucoup !!!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message