Additionner des denominateur et numerateur « textes »

Forum pour partager vos connaissances et vos astuces Excel / VBA ...
JimFisher
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 16 mai 2018
Version d'Excel : 2010

Message par JimFisher » 16 mai 2018, 08:13

Bonjour,

J’ai besoin de votre aide.
Je vous explique mon problème (en espérant qu’un génie trouve la solution).

J’ai plusieurs tableaux avec des fractions sous format textes. Je précise que ce n’est pas des fractions pour ma mes collègues et moi. Ce n’est qu’une forme d’ecriture.

De ce fait, j’ai une colonne qui regroupe plusieurs données du type
1/2
2/3
1/2
2/2
Je cherche la formule qui me permet d’additionner les differents numérateurs et les différents dénominateurs indépendant.

Ainsi je cherche à la fin obtenir pour :

1/2
2/3
1/2
2/2
=
6/9

Ce n’est qu’un exemple. Je cherche réellement a trouver la somme de tout ces valeurs sous format texte.

Puisque j’ai une trentaine de tableau à compter de cette manière et les compters à la main est une énorme source d’erreur et une perte de temps colossal....et accessoirement une perte de papiers...

En espérant avoir une aide. Je vous remercie d’avance.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 5227
Appréciations reçues : 102
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 16 mai 2018, 08:30

Bonjour le forum,

=SOMMEPROD(CNUM(GAUCHE(A2:A5;1)*1))&"/"&SOMMEPROD(CNUM(DROITE(A2:A5;1)*1))

Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 5227
Appréciations reçues : 102
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 16 mai 2018, 08:49

Re,

Si le numérateur ou le dénominateur contient un nombre à la place d'un chiffre :

=SOMMEPROD(CNUM(GAUCHE(A2:A5;TROUVE("/";A2:A5)-1)))&"/"&SOMMEPROD(CNUM(DROITE(A2:A5;NBCAR(A2:A5)-TROUVE("/";A2:A5))))
JimFisher
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 16 mai 2018
Version d'Excel : 2010

Message par JimFisher » 16 mai 2018, 09:09

Merci ! Beaucoup !!!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • écart entre 2 textes
    par chermiti » 11 novembre 2016, 08:11 » dans Excel - VBA
    2 Réponses
    88 Vues
    Dernier message par chermiti
    11 novembre 2016, 08:27
  • Récupération textes définis
    par jp65 » 2 mars 2014, 19:29 » dans Excel - VBA
    15 Réponses
    432 Vues
    Dernier message par jp65
    8 mars 2014, 17:43
  • Récupérer une partie de textes
    par primokorn » 4 avril 2018, 14:27 » dans Excel - VBA
    6 Réponses
    74 Vues
    Dernier message par archer
    4 avril 2018, 16:47
  • Nuage de points valeurs et textes
    par mazneoo » 19 mai 2015, 15:26 » dans Excel - VBA
    5 Réponses
    127 Vues
    Dernier message par mazneoo
    20 mai 2015, 09:22
  • UserForm avec textes variables
    par Yvouille » 13 août 2016, 09:14 » dans Excel - VBA
    10 Réponses
    203 Vues
    Dernier message par Yvouille
    14 août 2016, 21:55
  • Consolider des données textes
    par onizuka666 » 14 avril 2017, 16:31 » dans Excel - VBA
    4 Réponses
    148 Vues
    Dernier message par onizuka666
    18 avril 2017, 11:22