561 résultats trouvés

par jpbt84
21 décembre 2018, 11:45
Forum : Excel - VBA
Sujet : Indicateur dynamique
Réponses : 9
Vues : 211

Re: Indicateur dynamique

qassim a écrit :
21 décembre 2018, 10:59
ERRATUM je me suis mal exprimé je voulais plutot dire de cette façon
La date de fin de mois se calcul seul, c'est dans la formule, si il y a un besoin de borner l'analyse, il faut le dire !
par jpbt84
21 décembre 2018, 10:29
Forum : Excel - VBA
Sujet : Indicateur dynamique
Réponses : 9
Vues : 211

Re: Indicateur dynamique

Bonjour,

Voici une proposition à tester.
Copie de Historique.xlsx
(299.73 Kio) Téléchargé 33 fois
par jpbt84
27 novembre 2018, 18:47
Forum : Excel - VBA
Sujet : MFC suivant annee
Réponses : 7
Vues : 175

Re: MFC suivant annee

Bonsoir, Je suis d'accord avec toi Chris, pas d'importance des priorités si les tests ne se croisent pas, mais ici, ils se croisent. Toutes les dates de l'année en cours, avant ce jour et les dates de l'année en cours après ce jour répondent au critère trois, sauf à ajouter une autre condition, un p...
par jpbt84
27 novembre 2018, 14:24
Forum : Excel - VBA
Sujet : MFC suivant annee
Réponses : 7
Vues : 175

Re: MFC suivant annee

Bonjour, Pour cela, il te faut 3 MFC. Si les données sont positionnées à la même place que ton exemple (Ce qui n'est surement pas le cas et donc à adapter) Pour mettre en vert =ANNEE(A12)>ANNEE(AUJOURDHUI()) Pour mettre en rouge =A12<AUJOURDHUI() Pour mettre en jaune =ANNEE(A12)=ANNEE(AUJOURDHUI()) ...
par jpbt84
26 novembre 2018, 12:27
Forum : Excel - VBA
Sujet : Rechercher différentes chaines de caractères
Réponses : 4
Vues : 195

Re: Rechercher différetnes chaines de caractères

Bonjour,

A tester.
ex_recherche_chaine - V1.xlsx
(8.87 Kio) Téléchargé 44 fois
par jpbt84
25 novembre 2018, 19:30
Forum : Excel - VBA
Sujet : Somme d'élément quand égal à un certain texte
Réponses : 2
Vues : 97

Re: Somme d'élément quand égal à un certain texte

Bonjour,

La fonction SOMME.SI(), permet de faire cela !
par jpbt84
25 novembre 2018, 19:28
Forum : Excel - VBA
Sujet : si avec plusieurs conditions
Réponses : 4
Vues : 144

Re: si avec plusieurs conditions

Bonjour,

Indiquer ces valeurs dans votre premier tableau
A5 : 0
A6 : 4
A7 : 8
A8 : 9

Puis, voici la formule
=RECHERCHEV(C12;$A$5:$C$8;SI(B12<10;2;3);VRAI)
par jpbt84
9 octobre 2018, 11:41
Forum : Excel - VBA
Sujet : Double condition SI
Réponses : 5
Vues : 330

Re: Double condition SI

Voici la proposition :
=SI(OU(JOURSEM(B8;11)>=6;NB.SI(B8;Tableau3[Jours fériés])>=1);-1;0)
par jpbt84
9 octobre 2018, 10:42
Forum : Excel - VBA
Sujet : Double condition SI
Réponses : 5
Vues : 330

Re: Double condition SI

Bonjour,

Une possibilité !
=SI(ET(OU(A8="Sa";A8="Di");NB.SI(B8;Tableau3[Jours fériés])>=1);-1;0)
par jpbt84
8 octobre 2018, 09:23
Forum : Excel - VBA
Sujet : renvoyer un texte
Réponses : 2
Vues : 108

Re: renvoyer un texte

Bonjour,

Idéalement, dans ton onglet TOTAL (Je crois que c'est là que tu recherches la valeur), insère une colonne C, entre Ligne et Zone 1, cette colonne contiendra la concatenation de ta colonne Machine et Ligne, tu n'auras plus qu'à faire un petit RECHERCHEV() !!!!!