8824 résultats trouvés

par eriiic
il y a 13 minutes
Forum : Excel - VBA
Sujet : Calculer le nombre d'heures après 22h
Réponses : 15
Vues : 54

Re: Calculer le nombre d'heures après 22h

si rien n'est entré dans ces cellules C'est bien ce que j'avais lu. Je comprends les 2 cellules vides, il n'a pas dit dans une des cellules. Et pour moi une seule saisie c'est s'arrêter au milieu du gué, une erreur de saisie au même titre que si qq'un y met "toto" ce qui n'est pas testé non plus. M...
par eriiic
Aujourd’hui, 18:43
Forum : Excel - VBA
Sujet : Calculer le nombre d'heures après 22h
Réponses : 15
Vues : 54

Re: Calculer le nombre d'heures après 22h

Ah bon, tu as testé et tu n'obtiens pas 0 ?
Chez moi si ;-)
Etant entendu que c'est soit 2 saisies, soit aucune. Une seule c'est que c'est en cours de saisie
par eriiic
Aujourd’hui, 17:56
Forum : Excel - VBA
Sujet : Calculer le nombre d'heures après 22h
Réponses : 15
Vues : 54

Re: Calculer le nombre d'heures après 22h

Et cette proposition de 16h41 https://forum.excel-pratique.com/viewtopic.php?p=791638#p791638 ?
Si ce n'est que j'ai utilisé A2 et B2 au lieu de A1 et A2.
eric
par eriiic
Aujourd’hui, 16:41
Forum : Excel - VBA
Sujet : Calculer le nombre d'heures après 22h
Réponses : 15
Vues : 54

Re: Calculer le nombre d'heures après 22h

Bonjour à tous,

En supposant que la 1ère heure est toujours dans la soirée et que tu n'as jamais 1:00 à 3:00 par exemple :
=MAX(0;B2+(B2<A2)-MAX(A2;"22:00"))
sinon il faudra compléter
eric
par eriiic
Hier, 21:37
Forum : Excel - VBA
Sujet : Souci référence avec Indirect & Adresse
Réponses : 6
Vues : 43

Re: Souci référence avec Indirect & Adresse

Et pour s'amuser, avec recherche du nom de la colonne mis en ligne 1 des autres feuilles :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;EQUIV("Montant";INDIRECT("'"&$A2&" "&B$1&"'!$1:$1");0)-1))
Ici : "Montant"
eric
par eriiic
Hier, 21:17
Forum : Excel - VBA
Sujet : Souci référence avec Indirect & Adresse
Réponses : 6
Vues : 43

Re: Souci référence avec Indirect & Adresse

Bonjour à tous, bizarre, chez moi ça fonctionne : =SOMME(INDIRECT("'"&$A2&" "&B$1&"'!$C:$C")) par contre je n'ai pas bien compris si tu voulais avoir aussi C variable. Si c'est le cas : =SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;J1-1)) avec en J1 ton n° de colonne : 3 ou par sa lettre majus...
par eriiic
Hier, 21:07
Forum : Excel - VBA
Sujet : Fusion de cellules ayant le même mois référencé
Réponses : 3
Vues : 52

Re: Fusion de cellules ayant le même mois référencé

cette fusion ne pourrait être faite que par macro, je ne suis pas sûr que ça vaille le coup. Avec la MFC le visuel est presque identique. Tu peux même la compléter pour mettre les bordures verticales que là où c'est nécessaire et là ça sera identique
eric
par eriiic
Hier, 11:02
Forum : Excel - VBA
Sujet : Fusion de cellules ayant le même mois référencé
Réponses : 3
Vues : 52

Re: Fusion de cellules ayant le même mois référencé

Bonjour,

vu que tu veux une fusion de fusions ça va te faire pas mal de boulot.
Sélectionner AI17:CI17 et en MFC par formule :
=MOIS(AI17)=MOIS(AH17)
avec ploice jaune.
eric
par eriiic
Hier, 10:48
Forum : Excel - VBA
Sujet : Filtre manuels sur feuille protégée
Réponses : 2
Vues : 22

Re: Filtre manuels sur feuille protégée

Bonjour, dans le cas du lancement de l' une des macros Quelle précision... Sans doute rien à voir avec ton pb mais dans les options de VBE tu devrais cocher 'Déclaration obligatoire des variables. Ca te mettra Option Explicit à chaque nouveau module. Le mettre manuellement à ceux existants. Ca t'évi...
par eriiic
21 août 2019, 19:13
Forum : Excel - VBA
Sujet : Une solution "Plus rapide"
Réponses : 12
Vues : 165

Re: Une solution "Plus rapide"

PS : je viens de voir qu'il reste un Union(plJoint(i), plJoint(j)).Select qui me servait aux contrôles dans la fonction. A supprimer PS2 : Je viens de jeter un oeil et de comparer les versions. C'est même beaucoup plus conséquent que ce que je pensais la différence sur ce dessin. Je passe de 6.9s à ...