878 résultats trouvés

par ketamacanna
18 février 2014, 05:13
Forum : Excel - VBA
Sujet : recherche données, critère de plusieurs valeurs
Réponses : 8
Vues : 428

Re: recherche données, critère de plusieurs valeurs

Bonjour à vous deux, Une formule matricielle du genre : (à valider simultanément par ctrl+alt+enter) exemple1 retour.xlsx =SOMME((chiffrage!$F$5:$F$11)*(chiffrage!$B$5:$B$11=$B5)*(FREQUENCE(SI((chiffrage!$E$5:$E$10)<>TRANSPOSE(plage_exclusion);"";LIGNE($A$1:$A$6));LIGNE($A$1:$A$6))=0)) Dans la colon...
par ketamacanna
18 février 2014, 01:23
Forum : Excel - VBA
Sujet : Extraire des données
Réponses : 3
Vues : 214

Re: Extraire des données

Bonsoir,

Avec l'utilisation de la formule décaler + liste déroulante :
Exemple 2014 retour.xls
(35 Kio) Téléchargé 44 fois
Formule de la liste déroulante en I2:

=DECALER(Produits!$B$1;EQUIV(Produits!$H$2;Produits!$A$1:$A$100;0)-1;;NB.SI(Produits!$A$1:$A$100;Produits!$H$2))

cdt
par ketamacanna
14 février 2014, 02:52
Forum : Excel - VBA
Sujet : trouver des correspondances entre plusieurs tableaux
Réponses : 6
Vues : 206

Re: trouver des correspondances entre plusieurs tableaux

Bonsoir Yvouille, Joes :

Sur la base du fichier d'Yvouille en modfiant un peu la formule mais en gardant le même raisonnement :
=SI((NB.SI(F:F;C2)*NB.SI(I:I;C2))>0;RECHERCHEV(C2;F:G;2;0)+RECHERCHEV(C2;I:J;2;0)+D2;D2)
retourV1.xls
(28 Kio) Téléchargé 47 fois
cdt
par ketamacanna
13 février 2014, 22:23
Forum : Excel - VBA
Sujet : Explications
Réponses : 4
Vues : 300

Re: Explications

Bonsoir, =E2*VLOOKUP(Feuille1!$F2,BD!$C$2:$J$8,MATCH($H$9,Feuille2!$D$1:$J$1,0)+1,FALSE) Je multiplie la valeur présente dans la cellule E2 par celle retournée par la fonction vlookup (recherchev) La valeur retournée par la fonction vlookup se détermine ainsi : Je recherche tout d'abord la valeur de...
par ketamacanna
13 février 2014, 02:09
Forum : Excel - VBA
Sujet : Recherche Multi reponses
Réponses : 6
Vues : 328

Re: RECHERCHE MULTI REPONSES

Bonsoir, Je ne sais pas si c'est ce que tu attends, voici un essai : par contre tu n'as pas précisé si il y a plusieurs fois le même numéro comment tu veux gérer le problème : exemple dans le fichier ci dessous dans l'onglet résultat, la cellule D3 = 1122 et G3 = 1122 (est-ce normal ?) exemple-4 RET...
par ketamacanna
13 février 2014, 01:36
Forum : Excel - VBA
Sujet : Mise en forme automatique
Réponses : 6
Vues : 386

Re: Mise en forme automatique

Oui c'est possible :)
A tester
mfcv3.xlsx
(31.62 Kio) Téléchargé 52 fois
cdt
par ketamacanna
13 février 2014, 01:21
Forum : Excel - VBA
Sujet : Calculer un nombre sur deux colonnes
Réponses : 3
Vues : 190

Re: Calculer un nombre sur deux colonnes

Bonsoir,

Ma petite contribution
Calcul Hyppique retour.xlsx
(24.74 Kio) Téléchargé 45 fois
cdt

Bonsoir R@chid : même formule à peu de chose près :)

=SIERREUR(PETITE.VALEUR(SI($K$3:$K$22=GAUCHE($M2;TROUVE(" ";$M2)-1)*1;$J$3:$J$22);COLONNE(A1));"")
par ketamacanna
13 février 2014, 01:03
Forum : Excel - VBA
Sujet : Clacul selon plusieurs plusieurs critères
Réponses : 6
Vues : 582

Re: Clacul selon plusieurs plusieurs critères

Bonsoir Banzai, didier83 : C'est vrai que c'est un peu l'usine à gaz le fichier mais je te propose tout de même le fichier ci-dessous : Classeurs fruits 2014 retour.xls Petite précision : pour le total de la colonne produit ; on ne travaille que sur la colonne AJ ou alors c'est le somme de AJ +AK At...
par ketamacanna
12 février 2014, 20:51
Forum : Excel - VBA
Sujet : Mise en forme automatique
Réponses : 6
Vues : 386

Re: Mise en forme automatique

A tester
mfcv2.xlsx
(9.75 Kio) Téléchargé 52 fois
cdt
par ketamacanna
12 février 2014, 00:27
Forum : Excel - VBA
Sujet : Recherche Multi reponses
Réponses : 6
Vues : 328

Re: RECHERCHE MULTI REPONSES

Bonsoir,

Sans fichier c'est un peu difficile de t'apporter l'aide appropriée à ton tableau, il faudrait que tu joignes un fichier avec l'emplacement des tes tableaux, et où doit apparaître le nouveau tableau.
Un essai sur la base de tes maigres informations
matrice.xlsx
(9.52 Kio) Téléchargé 59 fois
cdt